HDU 5095

SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2
<-> p, y^2
<-> q, z^2
<-> r, xy
<-> u, yz
<-> v, zx
<-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.

Now your task is to write a program to change f into g.

    Input
    The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.

    Output
    For each input function, print its correspondent linear function with 9 variables in conventional way on one line.

    Sample Input
    2

0 46 3 4 -5 -22 -8 -32 24 27
2 31 -5 0 0 12 0 0 -49 12

    Sample Output
    46q+3r+4u-5v-22w-8x-32y+24z+27

2p+31q-5r+12w-49z+12

#include <iostream>
using namespace std;
int n[11];
char s[10]= {'p','q','r','u','v','w','x','y','z'};
int main()
{
    int a,i,t=0,g=0;
    cin >> a;
    while(a--)
    {
        t=0;
        g=0;
        for(i=0; i<10; i++)
        {
            cin >> n[i];
            if(n[i]==0)
            {
                g++;
            }
        }
        if(g==10)
        {
            cout << 0 << endl;;
        }
        else
        {
            for(i=0; i<9; i++)
            {
                if(n[i]!=0)
                {
                    t++;
                }
                if(n[i]==0)
                {
                    continue;
                }
                else if(n[i]<0&&n[i]!=-1)
                {
                    cout << n[i] << s[i];
                }
                else if(n[i]>0&&n[i]!=1)
                {
                    if(t==1)
                    {
                        cout << n[i] << s[i];
                    }
                    else
                    {
                        cout << "+";
                        cout << n[i] << s[i];
                    }
                }
                else if(n[i]==-1)
                {
                    cout << "-" << s[i];
                }
                else if(n[i]==1)
                {
                    if(t==1)
                    {
                        cout << s[i];
                    }
                    else
                    {
                        cout << "+";
                        cout << s[i];
                    }
                }
            }
            if(n[9]!=0)
            {
                if(n[9]<0)
                {
                    cout << n[9];
                }
                else if(n[9]>0)
                {
                    if(t!=0)
                    {
                        cout << "+";
                        cout << n[9];
                        t=0;
                    }
                    else
                    {
                        cout << n[9];
                    }
                }
            }
            cout << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值