B君和G君聊天的时候想到了如下的问题。
给定自然数l和r ,选取2个整数x,y满足l <= x <= y <= r ,使得x|y最大。
其中|表示按位或,即C、 C++、 Java中的|运算。
Input
包含至多10001组测试数据。
第一行有一个正整数,表示数据的组数。
接下来每一行表示一组数据,包含两个整数l,r。
保证 0 <= l <= r <= 10181018。
Output
对于每组数据输出一行,表示最大的位或。
Sample Input
5
1 10
0 1
1023 1024
233 322
1000000000000000000 1000000000000000000
Sample Output
15
1
2047
511
1000000000000000000
#include<bits/stdc++.h>
using namespace std;
int a[105];
int ans[50005];
int b[105];
long long int pow(int x)
{
long long int ss=1;
for(int i=0;i<x;i++)
{
ss=ss*2;
}
return ss;
}
int main()
{
int T;
scanf("%d",&T);
long long int n,m;
int cnt;
long long int sum=0;
while(T--)
{
scanf("%I64d%I64d",&n,&m);
long long int maxx=m;
int ll,rr;
int cnt=0;
while(m>0)
{
ans[cnt++]=(m&1);
m/=2;
}
sum=0;
for(int i=0;i<cnt;i++)
{
if(ans[i]==0)
{
if((maxx-sum-1)>=n)
ans[i]=1;
}
else
sum+=pow(i);
}
sum=0;
for(int i=0;i<cnt;i++)
{
if(ans[i])
{
sum+=pow(i);
}
}
cout<<sum<<endl;
}
}