K - How many prime numbers

K - How many prime numbers

Give you a lot of positive integers, just to find out how many prime numbers there are.
Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
Output
For each case, print the number of prime numbers you have found out.
Sample Input

3
2 3 4

Sample Output

2
#include <iostream>
#include <math.h>
#include <stdio.h>
using namespace std;

int xuan(int a)
{
    int i;
    int t=(int)sqrt(a);
    for(i=2; i<=t; i++)
    {
        if(a%i==0)
        {
            return 0;
        }
    }
    return 1;
}

int main()
{
    int a,b,i;
    int sum;
    while(scanf("%d",&a)!=EOF)
    {
        sum=0;
        for(i=1; i<=a; i++)
        {
            scanf("%d",&b);
            if(b==2)
            {
                sum=sum+1;
            }
            else
            {
                if(b%2==1)
                {
                    if(xuan(b)==1)
                    {
                        sum=sum+1;
                    }
                }
            }
        }
        cout << sum << endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值