J - Floating Point Presentation HDU - 1265

 Do you know IEEE's constact of single floating point data? If you are not sure, following is the contract:



This problem is really simple for you: please convert the real data into the IEEE single floating point data presentation.

Input
There are N(1<=N<=150) real data need to be converted. Real data can be negative, zero, and positive.
Output
For each real data, print the IEEE single floating point data presentation in upper case hexadecimal letters in a single line.
Sample Input

2
23.85
-23.85

Sample Output

41BECCCD
C1BECCCD
#include<stdio.h>
#include<string.h>
int main()
{
    long n,x;
    float m;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%f",&m);
        memcpy(&x,&m,4);
        printf("%lX\n",x);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值