I - Keep the Customer Satisfied(30) UVA - 1153

Simon and Garfunkel Corporation (SG Corp.) is a large steel-making company with thousand of
customers. Keeping the customer satis ed is one of the major objective of Paul and Art, the managers.
Customers issue orders that are characterized by two integer values
q
, the amount of steel required
(in tons) and
d
, the due date (a calender date converted in seconds). The due date has to be met if SG
Corp. accepts the order. Stated another way, when an order is accepted, the corresponding amount
of steel has to be produced before its due date. Of course, the factory can process no more than one
order at a time.
Although the manufacturing process is rather complex, it can be seen as a single production line
with a constant throughput. In the following,
we assume that producing
q
tons of steel takes exactly
q
seconds
(i.e., throughput is 1). The factory runs on a monthly production plan. Before the beginning of
the month, all customers’ orders are collected and Paul and Art determine which of them are going to
be
accepted
and which ones are to be
rejected
in the next production period. A production schedule is
then designed. To keep customers satis ed, Paul and Art want to
minimize the total number of orders
that are rejected
. In the following, we assume that the beginning of the next production plan (i.e., the
rst day of the next month) corresponds to date 0.
Hogdson and Moore have been appointed as Chief Scienti c Officers and you are requested to help
them to compute an optimal solution and to build a schedule of all accepted orders (starting time and
completion time).
Small Example
Consider the following data set made of 6 orders
J
1
;:::;J
6
. For a given order,
J
j
,
q
j
denotes the
amount of steel required and
d
j
is the associated due date.
Order
q
j
d
j
J
1
6
8
J
2
4
9
J
3
7
15
J
4
8
20
J
5
3
21
J
6
5
22
You can check by hand that all orders cannot be accepted and it’s very unlikely you could nd a
solution with less than two rejected orders. Here is an optimal solution: Reject
J
1
and
J
4
, accept all
other orders and process them as follows.
Accepted Order
Starting Time
Completion Time
J
2
0
4
J
3
4
11
J
5
11
14
J
6
14
19
Note that the production line is never idle.
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases
following, each of them as described below. This line is followed by a blank line, and there is also a
blank line between two consecutive inputs.
Data Each test case is described by one input le that contains all the relevant data: The rst line
contains the number
n
of orders (
n
can be as large as 800000 for some test cases). It is followed by
n
lines. Each of which describes an order made of two integer values: the amount of steel (in tons)
required for the order (lower than 1000) and its due date (in seconds; lower than 2

10
6
).
Output
For each test case, you are required to compute an optimal solution and your program has to write the
number of orders that are accepted.
The outputs of two consecutive cases will be separated by a blank line.
Some Hints from Hogdson and Moore

Hogdson and Moore claim that it is optimal to sequence
accepted
orders in non-decreasing order
of due dates.

They also claim that there is an optimal solution such that for any two orders
J
u
and
J
v
with
q
u

q
v
and
d
u
<d
v
, if
J
u
is accepted then
J
v
is also accepted.

Finally, Hogdson and Moore advise you to \Keep the Customer Satis ed"
Keep the Customer Satis ed
(
©
Simon & Garfunkel)
Gee but it’s great to be back home
Home is where I want to be.
I’ve been on the road so long my friend,
And if you came along
I know you couldn’t disagree.
It’s the same old story
Everywhere I go,
I get slandered,
Libeled,
I hear words I never heard
In the bible
And I’m on step ahead of the shoe shine
Two steps away from the county line
Just trying to keep my customers satisfied,
Satisfied.
Deputy sheriff said to me
Tell me what you come here for, boy.
You better get your bags and flee.
You’re in trouble boy,
And you’re heading into more.
Sample Input
1
6
7 15
8 20
6 8
4 9
3 21
5 22
Sample Output
4

#include<bits/stdc++.h>
using namespace std;
const int maxn = 800000 + 5;
int T,n;
struct node
{
    int l,r;
} a[maxn];
bool cmp(node a,node b)
{
    return a.r < b.r ;            //**
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&a[i].l,&a[i].r);
        }
        sort(a,a+n,cmp);
        priority_queue<int> q;
        int ans = 0,time = 0;
        for(int i=0; i<n; i++)
        {
            q.push(a[i].l);
            int t = q.top();          //加入当前的人
            time += a[i].l;
            ans ++;
            if(time > a[i].r)
            {
                time -= t;
                q.pop();
                ans --; //删除消耗时间最长的人,为后面的人留出更多的时间
            }
        }
        printf("%d\n",ans);
        if(T)
        {
            printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值