Vacation(HDU)物理题

Vacation

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0
Special Judge

 

Problem Description

Tom and Jerry are going on a vacation. They are now driving on a one-way road and several cars are in front of them. To be more specific, there are n cars in front of them. The ith car has a length of li, the head of it is si from the stop-line, and its maximum velocity is vi. The car Tom and Jerry are driving is l0 in length, and s0from the stop-line, with a maximum velocity of v0.
The traffic light has a very long cycle. You can assume that it is always green light. However, since the road is too narrow, no car can get ahead of other cars. Even if your speed can be greater than the car in front of you, you still can only drive at the same speed as the anterior car. But when not affected by the car ahead, the driver will drive at the maximum speed. You can assume that every driver here is very good at driving, so that the distance of adjacent cars can be kept to be 0.
Though Tom and Jerry know that they can pass the stop-line during green light, they still want to know the minimum time they need to pass the stop-line. We say a car passes the stop-line once the head of the car passes it.
Please notice that even after a car passes the stop-line, it still runs on the road, and cannot be overtaken.

 

 

Input

This problem contains multiple test cases.
For each test case, the first line contains an integer n (1≤n≤105,∑n≤2×106), the number of cars.
The next three lines each contains n+1 integers, li,si,vi (1≤si,vi,li≤109). It's guaranteed that si≥si+1+li+1,∀i∈[0,n−1]

 

 

Output

For each test case, output one line containing the answer. Your answer will be accepted if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a, and the jury's answer is b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6.
The answer is guaranteed to exist.

 

 

Sample Input

 

1 2 2 7 1 2 1 2 1 2 2 10 7 1 6 2 1

 

 

Sample Output

 

3.5000000000 5.0000000000

 

#include<cstdio>
using namespace std;
const int  INF = 0x3f3f3f3f;
struct node
{
    int l, s, v;
    int s2;
    double t, t2;
} car[100005];

int n;

void input()
{
    for(int i = n; i >= 0; i--)
    {
        scanf("%d", &car[i].l);
    }
    for(int i = n; i >= 0; i--)
    {
        scanf("%d", &car[i].s);
    }
    long l1 = -car[n].l;
    for(int i = n; i >=0; i--)
    {
        car[i].s2 = car[i].s+l1+car[i].l;
        l1+=car[i].l;
    }
    for(int i = n ; i >= 0; i--)
    {
        scanf("%d", &car[i].v);
    }
}

int main()
{
    while(~scanf("%d", &n))
    {
        input();
        for(int i = 0; i <= n; i++)
        {
            if(i != 0 && car[i].v*car[i-1].t2 > car[i].s2)
            {
                car[i].t2 = car[i-1].t2;
            }
            else
            {
                car[i].t2 = car[i].s2*1.0/car[i].v;
            }
        }
        printf("%.10lf\n", car[n].t2);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值