G - Find a way (bfs)

G - Find a way

 

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 

Input

The input contains multiple test cases. 
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character. 
‘Y’ express yifenfei initial position. 
‘M’    express Merceki initial position. 
‘#’ forbid road; 
‘.’ Road. 
‘@’ KCF 

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66

//Full of love and hope for life


#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdio.h>
#include <queue>
using namespace std;

struct node{
    int x,y,step;
};

node n,m;
int flag[210][210];
char s[210][210];
int ss[210][210];
int a,b;
int nex[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};

void bfs(int x,int y)
{
    queue<node>q;
    n.x=x;
    n.y=y;
    n.step=0;
    q.push(n);
    while(!q.empty()){
        m=q.front();
        q.pop();
        for(int i=0; i<4; i++){
            n.x=m.x+nex[i][0];
            n.y=m.y+nex[i][1];
            if(s[n.x][n.y]=='#'||n.x<=0||n.x>a||n.y<=0||n.y>b)//不能越界{
                continue;
            }
            if(flag[n.x][n.y]==0){
                flag[n.x][n.y]=1;
                n.step=m.step+1;
                ss[n.x][n.y]+=n.step;
                q.push(n);
            }
        }
    }
}

int main()
{
    int ma;
    while(cin >> a >> b){
        memset(ss,0,sizeof(ss));
        ma=500;
        for(int i=1; i<=a; i++){
            for(int j=1; j<=b; j++)
            {
                cin >> s[i][j];
            }
        }
        for(int i=1; i<=a; i++){
            for(int j=1; j<=b; j++){
                if(s[i][j]=='M'||s[i][j]=='Y'){
                    memset(flag,0,sizeof(flag));
                    bfs(i,j);//使两人到各各可通行的点的距离记录在ss二维数组中
                }
            }
        }
        for(int i=1; i<=a; i++){
            for(int j=1; j<=b; j++){
                if(s[i][j]=='@'&&ma>ss[i][j]&&ss[i][j]!=0){
                    ma=ss[i][j];//找到一个最短的到kfc的时间
                }
            }
        }
        cout << ma*11 << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值