数据结构实验之查找三:树的种类统计
Time Limit: 400 ms Memory Limit: 65536 KiB
Problem Description
随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。
Input
输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。
Output
按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。
Sample Input
2
This is an Appletree
this is an appletree
Sample Output
this is an appletree 100.00%
one用链表做
//Full of love and hope for life
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include<bits/stdc++.h>
using namespace std;
struct node
{
char name[22];
int cnt;
node *l,*r;
};
int n;
node *creat(node*head,char *s)
{
if(!head)
{
head=new node;
head->cnt=1;
strcpy(head->name,s);
head->l=NULL;
head->r=NULL;
}
else
{
int cmp=strcmp(head->name,s);
if(cmp>0)
{
head->l=creat(head->l,s);
}
else if(cmp<0)
{
head->r=creat(head->r,s);
}
else
{
head->cnt++;
}
}
return head;
}
void mid(node *head)
{
if(head)
{
mid(head->l);
printf("%s %.2lf%c\n",head->name,head->cnt*100.0/n,'%');
mid(head->r);
}
}
int main()
{
node *head=NULL;
char w[22];
cin>>n;
getchar();//输入的回车也算了一个字符
for(int j=0; j<n; j++)
{
gets(w);
for(int i=0; w[i]; i++)
{
if(w[i]>='A'&&w[i]<='Z')
{
w[i]+=32;
}
}
head=creat(head,w);
}
mid(head);
return 0;
}
two map做法
//Full of love and hope for life
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include<bits/stdc++.h>
#include <map>
using namespace std;
map<int,string>mp;
int a[100100];
char s[100];
void become(int n)
{
for(int i=0; i<n; i++)
{
if(s[i]>='A' && s[i]<='Z')
{
s[i]=s[i]-'A'+'a';
}
}
}
int main ()
{
int n;
scanf("%d",&n);
getchar();
memset(a,0,sizeof(a));
int px=0;
for(int i=0; i<n; i++)
{
gets(s);
int m=strlen((s));
become(m);
int flag=0;
for(int i=0; i<px; i++)
{
if(mp[i]==s)
{
flag=1;
a[i]++;
break;
}
}
if(!flag)
{
mp[px]=s;
a[px]++;
px++;
}
}
string t;
int k;
for(int i=0; i<px-1; i++)
{
for(int j=i+1; j<px; j++)
{
if(mp[j]<mp[i])
{
t=mp[i];
mp[i]=mp[j];
mp[j]=t;
k=a[i];
a[i]=a[j];
a[j]=k;
}
}
}
for(int i=0; i<px; i++)
{
cout<<mp[i]<<" ";
a[i]*=100;
printf("%.2lf%%\n",(double)a[i]/n);
}
return 0;
}