数据结构实验之查找三:树的种类统计(链表)

数据结构实验之查找三:树的种类统计

Time Limit: 400 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

Input

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

Output

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

Sample Input

2
This is an Appletree
this is an appletree

Sample Output

this is an appletree 100.00%

one用链表做


//Full of love and hope for life


#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include<bits/stdc++.h>

using namespace std;

struct node
{
    char name[22];
    int cnt;
    node *l,*r;
};
int n;

node *creat(node*head,char *s)
{
    if(!head)
    {
        head=new node;
        head->cnt=1;
        strcpy(head->name,s);
        head->l=NULL;
        head->r=NULL;
    }
    else
    {
        int cmp=strcmp(head->name,s);
        if(cmp>0)
        {
            head->l=creat(head->l,s);
        }
        else if(cmp<0)
        {
            head->r=creat(head->r,s);
        }
        else
        {
            head->cnt++;
        }
    }
    return head;
}

void mid(node *head)
{
    if(head)
    {
        mid(head->l);
        printf("%s %.2lf%c\n",head->name,head->cnt*100.0/n,'%');
        mid(head->r);
    }
}

int main()
{
    node *head=NULL;
    char w[22];
    cin>>n;
    getchar();//输入的回车也算了一个字符
    for(int j=0; j<n; j++)
    {

        gets(w);
        for(int i=0; w[i]; i++)
        {
            if(w[i]>='A'&&w[i]<='Z')
            {
                w[i]+=32;
            }
        }
        head=creat(head,w);
    }
    mid(head);
    return 0;
}

two  map做法


//Full of love and hope for life


#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include<bits/stdc++.h>
#include <map>

using namespace std;

map<int,string>mp;

int a[100100];
char s[100];

void become(int n)
{
    for(int i=0; i<n; i++)
    {
        if(s[i]>='A' && s[i]<='Z')
        {
            s[i]=s[i]-'A'+'a';
        }
    }
}

int main ()
{
    int n;
    scanf("%d",&n);
    getchar();
    memset(a,0,sizeof(a));
    int px=0;
    for(int i=0; i<n; i++)
    {
        gets(s);
        int m=strlen((s));
        become(m);
        int flag=0;
        for(int i=0; i<px; i++)
        {
            if(mp[i]==s)
            {
                flag=1;
                a[i]++;
                break;
            }
        }
        if(!flag)
        {
            mp[px]=s;
            a[px]++;
            px++;
        }
    }
    string t;
    int k;
    for(int i=0; i<px-1; i++)
    {
        for(int j=i+1; j<px; j++)
        {
            if(mp[j]<mp[i])
            {
                t=mp[i];
                mp[i]=mp[j];
                mp[j]=t;
                k=a[i];
                a[i]=a[j];
                a[j]=k;
            }
        }
    }
    for(int i=0; i<px; i++)
    {
        cout<<mp[i]<<" ";
        a[i]*=100;
        printf("%.2lf%%\n",(double)a[i]/n);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值