A - Number Sequence (数组kmp)

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

kmp不止可以用在字符串,还可以用在数字上……(笑着哭)

代码:


//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

int nex[10010];
int n[1000010],m[10010];

void getnext(int a[],int x){
    int j=-1;
    nex[0]=-1;
    for(int i=1;i<x;i++){
        if(j!=-1&&a[i]!=a[j+1]){
            j=nex[j];
        }
        if(a[i]==a[j+1]){
            j++;
        }
        nex[i]=j;
    }
}

int kmp(int a[],int b[],int x,int y){
     getnext(b,y);
     int j=0;
    for(int i=0;i<x;i++){
        while(j!=-1&&a[i]!=b[j+1]){
             j=nex[j];
        }
        if(a[i]==b[j+1]){
            j++;
        }
        if(j==y-1){
            return i-j+1;
        }
    }
    return -1;
}

int main(){
    //ios::sync_with_stdio(false);
    int a,b,c;
    scanf("%d",&a);
    while(a--){
        scanf("%d%d",&b,&c);
        for(int i=0;i<b;i++){
            scanf("%d",&n[i]);
        }
        for(int i=0;i<c;i++){
            scanf("%d",&m[i]);
        }
        if(b<c){
            cout << -1 << endl;
        }
        else{
        cout << kmp(n,m,b,c) << endl;
        }
    }
    return 0;
}

//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

int nex[10010];
int n[1000010],m[10010];

void getnext(int a[],int x){
    int j=-1;
    nex[0]=-1;
    int i=0;
    while(i<x){
        if(j==-1||a[i]==a[j]){
            i++;
            j++;
            nex[i]=j;
        }
        else{
            j=nex[j];
        }
    }
}

int kmp(int a[],int b[],int x,int y){
     getnext(b,y);
     int j=0;
     int i=0;
     while(i<x&&j<y){
        if(j==-1||n[i]==m[j]){
            i++;
            j++;
        }
        else {
            j=nex[j];
        }
     }
     if(j>=y){
        return i-j+1;
        }
     else{
        return -1;
     }
}

int main(){
    //ios::sync_with_stdio(false);
    int a,b,c;
    scanf("%d",&a);
    while(a--){
        scanf("%d%d",&b,&c);
        for(int i=0;i<b;i++){
            scanf("%d",&n[i]);
        }
        for(int i=0;i<c;i++){
            scanf("%d",&m[i]);
        }
        if(b<c){
            cout << -1 << endl;
        }
        else{
        cout << kmp(n,m,b,c) << endl;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值