A number sequence(数论)

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

InputThe input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

OutputFor each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
题意:求给出A,B,n的f[n]的值,并取模于7,有f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

解题思路:这个思想很简单,直接循环求出就可以了,但是有一个问题,那就是n的范围很大,这就暴力循环的话很容易超时,而且这题一定不是看着这样简单,首先分析一个数取模7的话有七种可能0,1,2,3,4,5,6;所以由上面表达式可为f(n) = (A * f(n - 1) mod 7 + B * f(n - 2) mod 7) 由此可见,f[n]只有49中情况,然后再根据一个样列推出前50项,可以发现是周期为49循环的数,所以只需要求f[n%49]就行。

#include <iostream>
#include<cstdio>
using namespace std;
#define mod 7
int f[50];
int main()
{
	int a,b;
	long long n;
	while(scanf("%d%d%lld",&a,&b,&n))
	{
		if(!a&&!b&&!n)
			break;
		f[1]=f[2]=1;
		for(int i=3;i<=49;i++)
			f[i]=(a*f[i-1]+b*f[i-2])%mod;
		printf("%d\n",f[n%49]);
	}
	return 0;

}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值