F - Power Strings (kmp的nex数组)

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

最长公共前后缀


//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

char n[1000010];
int nex[1000010];

void getnext(char a[],int x){
    int j=-1;
    nex[0]=-1;
    int i=0;
    while(i<x){
        if(j==-1||a[i]==a[j]){
            i++;
            j++;
            nex[i]=j;
        }
        else{
            j=nex[j];
        }
    }
}

/*
int kmp(char a[],char b[],int x,int y){
     getnext(b,y);
     int j=-1;
     for(int i=0;i<x;i++){
        while(j!=-1&&a[i]!=b[j+1]){
             j=nex[j];
        }
        if(a[i]==b[j+1]){
            j++;
        }
        if(j==y-1){
            ans++;
        }
    }
    return ans;
}
*/

int main(){
    while(scanf("%s",n)){
        if(n[0]=='.'){
            break;
        }
        int len=strlen(n);
        getnext(n,len);
        int t=len-nex[len];
        if(len%t==0){
            cout << len/t << endl;
        }
        else{
            cout << 1 << endl;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值