C - Aladdin and the Flying Carpet (唯一分解定理+约数定理)

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

   思路:直接计算n的约数的个数+唯一分解定理!!!!学习一下公式(百度百科)
    

这里约数的个数需要变为一般,因为两边会有重复的,这里题目指出不是正方形,所以排除x*x = a的情况;

如果b*b > a 则输出0个

否则从1 -> (b-1)判断是否有a的约数,找到则删去就行啦!!!

定理https://blog.csdn.net/jianxingzhang/article/details/81503148

代码:


//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

typedef long long ll;
const ll maxn=1e6+100;

ll cnt=0;
ll prime[maxn];
ll vis[maxn];

void init(){//素数筛
    vis[1]=1;
    for(ll i=2;i<=1000010;i++){//一定要大于1000000
        if(vis[i]==0){
            for(ll j=i+i;j<=1000010;j+=i){//一定要大于1000000
                vis[j]=1;
            }
        }
    }
    for(ll i=2;i<1000010;i++){//找出所有素数
        if(vis[i]==0){
            prime[cnt++]=i;
        }
    }
}

ll findx(ll a,ll b){//唯一分解定理
     ll ans=1;
     ll k=a;
     for(ll i=0;i<cnt&&k>1&&prime[i]*prime[i]<=k;i++){
        if(k%prime[i]==0){
            ll c=0;
            while(k%prime[i]==0){//找约数
                k/=prime[i];
                c++;
            }
            ans*=(c+1);
        }
     }
     if(k>1){
        ans*=2;
     }
     ans/=2;
     if(b*b>a){
        ans=0;
     }
     else{
        for(int i=1;i<b;i++){
            if(a%i==0){
                ans-=1;
            }
        }
     }
     return ans;
}

int main(){
    ll T,k=0,a,b;
    cin >> T;
    memset(vis,0,sizeof(vis));
    init();
    while(T--){
            k++;
       cin >> a >> b;
       cout << "Case " << k << ": ";
       cout << findx(a,b) << endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值