C - Aladdin and the Flying Carpet(算术基本定理)

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.
Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.
Output

For each case, print the case number and the number of possible carpets.
Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2
算术基本定理:

      分解素因数:n=(p1^k1)*(p2^k2)*...*(pn*kn).(分解方式唯一)

      n的约数个数为cnt(n)=(1+k1)*(1+k2)*...*(1+kn).
先求出a的约数个数cnt(a),再暴力枚举出[1,b)中a的约数c,cnt/2-c即为答案。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#define MAXN 1000100
using namespace std;
int prime[1000100];
bool book[1000100];
int top;
void isprime()//素数筛
{
   memset(book, true, sizeof(book));
   book[1] = false;
   for(int i=2;i<MAXN;i++)
   {
     if(book[i])
     {
        for(int j=i+i;j<MAXN;j+=i)
        {
           book[j] = false;
        }
     }
   }
   for(int i=2;i<=MAXN;i++)
   {
     if(book[i])
     {
        prime[++top] = i;
     }
   }
}
int main()
{
   long long int T, n, m;
   scanf("%lld", &T);
   top = -1;
   isprime();
   for(long long int t = 1;t<=T;t++)
   {
      scanf("%lld %lld", &n, &m);
       long long int a = n;
       long long int cnt = 1;
       for(long long int i=0;i<=top&&prime[i]<a;i++)//分解定理
       {
          int k = 0;
          while(a%prime[i]==0)
          {
            a /= prime[i];
            k++;
          }
          cnt *= (1 + k);
       }
       if(a>1)
       cnt *= (1 + 1);
       if(m*m>n)
       {
         printf("Case %lld: %d\n", t, 0);
       }
       else
       {
         long long int ans = 0;
         for(long long int i=1;i<m;i++)
         {
           if(n%i==0)
           ans++;
         }
         printf("Case %lld: %lld\n", t, cnt/2 - ans);
       }
   }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值