E - Leading and Trailing (快速幂取模)

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

思路:后三位很好求,快速幂取模就好了,同样前三位我们也可以模拟快速幂来写,用double存储答案,模拟一下快速幂,中间记得转换就好了,注意输出为3位,如果后三位是022,那么必须输出022,不能输出22

代码:


//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

typedef long long ll;
const ll maxn=1e6+100;

double check(double a){
    if(a>=1000.0){
        while(a>=1000.0){
            a/=10.0;
        }
    }
    return a;
}

double quickmi1(double a,ll x){
    double ans=1.0;
    while(x){
        if(x&1){
            ans=ans*a;
            ans=check(ans);
        }
        a=a*a;
        a=check(a);
        x/=2;
    }
    return ans;
}

ll quickmi2(ll a,ll x){
    ll ans=1;
    while(x){
        if(x&1){
            ans=(ans*a)%1000;
        }
        a=(a*a)%1000;
        x/=2;
    }
    return ans;
}

int main(){
    ll T,a,b,k=0;
    cin >> T;
    while(T--){
        k++;
        cin >> a >> b;
        double n=a*1.0;
        printf("Case %lld: %d %03lld\n",k,(int)quickmi1(n,b),quickmi2(a,b));
    }
    return 0;
}

//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

typedef long long ll;
const ll maxn=1e6+100;

double check(double a){
    if(a>=1000.0){
        while(a>=1000.0){
            a/=10.0;
        }
    }
    return a;
}

double quickmi1(double a,ll x){
    double ans=1.0;
    while(x){
        if(x&1){
            ans=ans*a;
            ans=check(ans);
        }
        a=a*a;
        a=check(a);
        x/=2;
    }
    return ans;
}

int quickmi2(int a,int x){
    int ans=1;
    int t=a%1000;
    while(x){
        if(x&1){
            ans=(ans*t)%1000;
        }
        t=(t*t)%1000;
        x/=2;
    }
    return ans;
}

int main(){
    int T,a,b,k=0;
    cin >> T;
    while(T--){
        k++;
        cin >> a >> b;
        double n=(double)b*log10(a*1.0);
        n-=(int)n;
        double aa=pow(10.0,n);
        printf("Case %d: %d %03d\n",k,(int)(aa*100),quickmi2(a,b));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值