E - Leading and Trailing ( 快速幂取前3位数 )

E - Leading and Trailing ( 快速幂取前3位数 )

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

题意:求n^{k}的前三位数和后三位数

思路:对于后三位数好求直接快速幂取模1000, 前三位数也是快速幂只不过把取摸操作变成了大于等于1000去掉最后一位就是re = re/10, 但是考虑到后面的数会进位,所以不能直接舍弃掉,所以用double来存,这样就不会损失精度了。 还有一点是输出yong%03d, 因为可能出现022的情况需要输出022而不是22 。

代码:

#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

ll qpow( double a, ll n )
{
    double re = 1;
    while ( n ) {
        if ( n&1 ) {
            re = re*a;
            while ( re>=1000.0) re/=10.0;
        }
        a = a*a;
        while (a>=1000) a/=10.0;
        n >>= 1;
    }
    return (ll)re;
}

ll qqpow( ll a, ll n )
{
    ll re = 1;
    while ( n ) {
        if ( n&1 ) {
            re = (re*a)%1000;
        }
        a = (a*a)%1000;
        n >>= 1;
    }
    return re;
}

int main()
{
    ll ji=1,i,listt,n,k;
    cin >> listt;
    while ( listt-- ) {
        cin >> n >> k;
        printf("Case %lld: %03lld %03lld\n",ji++,qpow(n,k),qqpow((double)n,k));
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值