杭电OJ 2629 Identity Card(C++)

Identity Card
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11638 Accepted Submission(s): 4278

Problem Description
Do you own an ID card?You must have a identity card number in your family’s Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it.
Here is the codes which represent the region you are in.

However,in your card,maybe only 33 appears,0000 is replaced by other numbers.
Here is Samuel’s ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).

Input
Input will contain 2 parts:
A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.

Output
Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.

Sample Input
1
330000198910120036

Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.

虽然这题很水,不过为了节省时间,还是推荐大家用C++去做了(看了一些博客的C做法,觉得有些散乱.)通过C++的字符串函数,这题是很简洁明了的。
AC代码如下:

#include<iostream>
using namespace std;
int main()
{
	int n;
	while(cin>>n)
	{
		while(n--)
		{
			string s,a,b,c,d; //以字符串形式读取
			cin>>s;
			a=s.substr(0,2);  //取字符串第1到3位,即出生地
			b=s.substr(10,2); //取字符串第10到12位,出生日
			c=s.substr(12,2); //取字符串第12到2位,出生月
			d=s.substr(6,4);  //取字符串第6到10位,出生年
			cout<<"He/She is from ";
			if(a=="33") cout<<"Zhejiang,";   //字符串比较
			else if(a=="11") cout<<"Beijing,";
			else if(a=="71") cout<<"Taiwan,";
			else if(a=="81") cout<<"Hong Kong,";
			else if(a=="82") cout<<"Macao,";
			else if(a=="54") cout<<"Tibet,";
			else if(a=="21") cout<<"Liaoning,";
			else if(a=="31") cout<<"Shanghai,";
			cout<<"and his/her birthday is on "<<b
			<<","<<c<<","<<d<<" based on the table."<<"\n";
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值