Large Division (大数取模)

一个大数对一个数取余,可以把大数看成各位数的权值与个位数乘积的和。

比如1234=((1 * 10 + 2) * 10 + 3) * 10 + 4,对这个数进行取余运算就是上面基本加和乘的应用。

int len = a. length ();
int ans = 0;
for (int i = 0; i < len; i ++){
ans = (ans * 10 + a[i] - '0') mod b;
}

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

​
#include <bits/stdc++.h>
using namespace std;
char str[10001];
int main()
{
	long long t,b;
	cin>>t;
	long long a=1;
	while(t--)
	{
	cin>>str>>b; 
	long long len=strlen(str);
	long long ans;
	if(str[0]!='-')
	ans=str[0]-'0';
	else
	ans=str[1]-'0';
	for(long long i=0;i<len-1;i++)
	{
		if(str[i]>='0'&&str[i]<='9')
		{ 
			ans=ans%b;
			ans=ans*10+str[i+1]-'0';
		}
	}
	ans=ans%b; 
	if(!ans)
		printf("Case %lld: divisible\n",a++);
		else
		printf("Case %lld: not divisible\n",a++);

}
 } 

​

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值