- 问题描述
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output
For each case, output the number.
Sample Input
12 2
2 3
Sample Output
7
2.算法
算法1解题思路
给出的是两个数这两个数可能不互质,如果还用容斥原理的模板会减去多余的内容,所以我们应该使用最小公倍数,这样再去求从1到n内的这几个因子的倍数的个数,这样才能求得正解
算法1.源代码
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll gcd(ll a,ll b)//最大公约数
{
return b? gcd(b,a%b) : a;
}
ll lcm(ll a,ll b)//最小公倍数
{
return a*b/gcd(a,b);
}
int main()
{
ll n,a1;
ll m,a[15];
while(cin>>n>>m)
{
ll cnt2=0;
for(int i=1;i<=m;i++)
{
cin>>a1;
if(a1!=0) a[cnt2++]=a1;//把0出去,0不能是任意数的倍数
}
ll SUM=0;
for(ll i=1;i<(1<<cnt2);i++)
{
ll sum=1,cnt=0;
for(int j=0;j<cnt2;j++)
{
if(1&(i>>j))
{
sum=lcm(sum,a[j]);//因为所给的不一定是互质的,所以应该用最小公倍数求解
cnt++;
}
}
if(cnt%2!=0)//奇数想加
{
SUM+=(n-1)/sum;
}
else//偶数相减
{
SUM-=(n-1)/sum;
}
}
cout<<SUM<<endl;
}
return 0;
}
3. 总结
给出因子的模板,因子可能不是互质的,所以应该使用最大公约数