L2-012 关于堆的判断

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10 

输出样例: 

F
T
F

小顶堆:每个结点的值都小于等于其左右孩子结点的值

主要是建堆难,每次输入一个结点都循环和父亲结点比较 (u/2就是父亲结点 (int)3/2=1,(int)2/2=1)1的左孩子是2右孩子是3

void up(int u){
    if(u==1)return ;
    while(u>1){//循环和父亲结点比较
        if(h[u]<h[u/2]){
            swap(h[u],h[u/2]);
            u=u/2;
        }
        else return ;
    }
	return ;
}
int main(){
	cin>>n>>m;
	for(int i=1;i<=n;i++){
		cin>>h[i];
		up(i);
	}
    return 0;
}

ac代码

#include<bits/stdc++.h>
using namespace std;
const int N=1e4+5;
int h[N];
int n,m,y;
string s;
void up(int u){
    if(u==1)return ;
    while(u>1){
        if(h[u]<h[u/2]){
            swap(h[u],h[u/2]);
            u=u/2;
        }
        else return ;
    }
	return ;
}
int yy(string s){//判断字符串属于命题的哪一种
	if(s.find("is the root")==0){
		return 1;//根
	}
	else if(s.find("and ")==0){
		int ans=0;
		for(int i=0;i<s.size();i++){
			if(s[i]>='0'&&s[i]<='9'){
				ans=ans*10+s[i]-'0';
			}
		}
		if(s.find("-")==string::npos)y=ans;//考虑存在负数
        else y=-ans;
		return 2;//兄弟
	}
	else if(s.find("is the")==0){
		int ans=0;
		for(int i=0;i<s.size();i++){
			if(s[i]>='0'&&s[i]<='9'){
				ans=ans*10+s[i]-'0';
			}
		}
		if(s.find("-")==string::npos)y=ans;//考虑存在负数
        else y=-ans;
		return 3;//父亲		
	}
	else if(s.find("is a")==0){
		int ans=0;
		for(int i=0;i<s.size();i++){
			if(s[i]>='0'&&s[i]<='9'){
				ans=ans*10+s[i]-'0';
			}
		}
		if(s.find("-")==string::npos)y=ans;//考虑存在负数
        else y=-ans;
		return 4;//孩子			
	}
}
int finds(int k){
	for(int i=1;i<=n;i++){
		if(h[i]==k){
			return i;
		}
	}
    return 0;
}
int main(){
	cin>>n>>m;
	for(int i=1;i<=n;i++){
		cin>>h[i];
		up(i);
	}
//  	for(int i=1;i<=n;i++){
//  		cout<<h[i]<<endl;
//  	}
	while(m--){
		int x;
		cin>>x;
		s.clear();
        getchar();
		getline(cin,s);
		if(yy(s)==1){
			if(finds(x)==1){
				cout<<"T"<<endl;
			}
			else cout<<"F"<<endl;
		}
		else if(yy(s)==2){
			if(finds(y)/2==finds(x)/2){
				cout<<"T"<<endl;
			}else cout<<"F"<<endl;
		}
		else if(yy(s)==3){
			if(finds(x)==finds(y)/2){
				cout<<"T"<<endl;
			}else cout<<"F"<<endl;
		}
		else if(yy(s)==4){
			if(finds(y)==finds(x)/2){
				cout<<"T"<<endl;
			}else cout<<"F"<<endl;
		}
		
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值