Largest Rectangle in a Histogram(poj2559)

Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
在这里插入图片描述
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

题目大意是给你几个矩形的高度,让你连成一个面积最大的矩形,这个矩形的所有高要是存在的;
这题应该是典型的单调栈,但是很难想;首先我们要建立一个矩形高度递增的栈,更重要的是还要维护每个进栈元素的最长宽度,这个还是要自己模拟,很难讲清楚;最后还要设a[n+1]=0,目的是最后让栈中所有元素都出栈;

代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#include<map>
#include<vector>
#include<set>
#include<math.h>
#include<queue>
#define LL long long 
using namespace std;
LL a[100100];
LL sta[100100];//栈 
LL len[100100];//累计宽度 
int main(){
	int n;
	while(scanf("%d",&n)==1){
		if(n==0) break;
		for(int i=1;i<=n;i++){
			scanf("%lld",&a[i]);
		}
		int ans=0;//栈的当前位置 
		LL Max=0;
		a[n+1]=0;
		for(int i=1;i<=n+1;i++){
			if(a[i]>sta[ans]){
				sta[++ans]=a[i];//直接进栈 
				len[ans]=1;//这个进栈元素的累计宽度为1 
			}
			else{//退栈 
				LL w=0;//退栈的总宽度,是下一个进栈元素的宽度 
				while(a[i]<sta[ans]&&ans){
					w+=len[ans]; 
					Max=max(Max,w*sta[ans]);
					ans--;
				}
				sta[++ans]=a[i];//进栈
				len[ans]=w+1;//进栈元素宽度更新
			}
		}
		printf("%lld\n",Max); 
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值