poj2559 Largest Rectangle in a Histogram 栈

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer  n, denoting the number of rectangles it is composed of. You may assume that  1<=n<=100000. Then follow  n integers  h1,...,hn, where  0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is  1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000


我们分别处理每一块高度的不变的情况下,找他左边第一个比他矮的,和右边第一个比他矮的。那个对于这个高度,我们的

面积就是(r-l)*h.

怎么找呢。

第一块2,l=0. 左边没有比他矮的。。

第二块1,l=0.左边没有比他矮的,也就是说左边的完全都可以满足第二块高度的需求。

第三块4,我们从栈中找第一个比他矮的,那就是第二块。l=2

第四块5,我们从栈中取出比他矮的,就是第三块。l=3;

第五块1,我们从栈中一直找,没有比他矮的,l=0;

第六块3,第五块比他矮,l=5;

同理第七块l=5;

这里我们注意,再找矮的过程中,遇到的比它高的,我们从栈中把那个删掉,因为它夹在矮的之间,没有意义。

对于第i块,我们记录左边开始找,第一个比第i块矮的。

得到 0 0 2 3 0 5 5 

之后从右边开始找,第一个比它矮的。

5 5 0 3 2 0 0


#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <iostream>
#include<stack>
#include <algorithm>
using namespace std;
long long sta[100010],h[100010],l[100010],r[100010];
int main()
{
    int n;
    int t;
    while(cin>>n&&n)
    {
        for(int i=1;i<=n;i++)
           cin>>h[i];
        t=0;
        for(int i=1;i<=n;i++)
        {
            
            while(t>0&&h[sta[t-1]]>=h[i])//
                  t--;
            if(t==0)
               l[i]=0;
            else
               l[i]=sta[t-1];
            sta[t++]=i;


        }
        t=0;
        for(int i=n;i>=1;i--)
        {
            while(t>0&&h[sta[t-1]]>=h[i])
             t--;
            if(t==0)
              r[i]=n;
            else
              r[i]=sta[t-1]-1;
            sta[t++]=i;


                cout<<l[i]<<endl;
        }
        long long ans=0;
        for(int i=1;i<=n;i++){
            ans=max(ans,h[i]*(r[i]-l[i]));
        }
        cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值