B - Big Event in HDU(01背包)

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1
Sample Output
20 10
40 40
思路:
嗯…刚开始也有点懵不是很理解 不过可以自己弄下数字来说

比如说

3

20 1

30 1

20 1

这样子的话总的是70 然后sum/2是35 只能放一个30的 也就是说利用01背包而言 第一个要么就是和第二个一样大 要么就是比第二个来的大sum-cost[sum/2]。即将所有的价值加起来,然后尽可能的平分。

AC完整代码
#include<iostream>
#include<deque>
#include<memory.h>
#include<stdio.h>
#include<map>
#include<string>
#include<algorithm>
#include<vector>
#include<math.h>
#include<stack>
#include<queue>
#include<set>
#define inf 1<<29
#define MAXV 4005
using namespace std;

int main()
{
    int dp[100003],digit[100005];
	int n;
    while(scanf("%d",&n)!=EOF)
    {
        int a,b,sum=0,k=1;
        if(n<0)
            break;
        memset(dp,0,sizeof(dp));
        memset(digit,0,sizeof(digit));
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            while(b--)
            {
                digit[k++]=a;
                sum+=a;
            }
        }
        for(int i=1;i<k;i++)
        {
            for(int j=sum/2;j>=digit[i];j--)
            {
                dp[j]=max(dp[j],dp[j-digit[i]]+digit[i]);
            }
        }
        printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值