Catch That Cow POJ - 3278(一维bfs)

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

const int maxn = 100000 + 5;
int dis[maxn];
int vis[maxn];
queue<int>Q;

void bfs()
{
	while (!Q.empty())
	{
		int now = Q.front();
		Q.pop();
		for (int i = 0; i < 3; i++)
		{
			int nex;
			if (i == 0)
				nex = now - 1;
			else if (i == 1)
				nex = now + 1;
			else
				nex = now * 2;
			if (nex >= 0 && nex <= 100000 && vis[nex] == 0)
			{
				vis[nex] = 1;
				dis[nex] = 1 + dis[now];
				Q.push(nex);
			}
		}
	}
}

int main()
{
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		while (!Q.empty())
		{
			Q.pop();
		}
		if (n >= m)
		{
			printf("%d\n", n - m);
			continue;
		}
		memset(vis, 0, sizeof(vis));
		memset(dis, 0, sizeof(dis));
		vis[n] = 1;
		Q.push(n);
		bfs();
		printf("%d\n", dis[m]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值