B - Proving Equivalences(强连通 加多少边使其强连通)

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

  1. A is invertible.
  2. Ax = b has exactly one solution for every n × 1 matrix b.
  3. Ax = b is consistent for every n × 1 matrix b.
  4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies ©, that © implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to ©, and that © is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.

  • m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
    Output
    Per testcase:

  • One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
    Sample Input
    2
    4 0
    3 2
    1 2
    1 3
    Sample Output
    4
    2
    题意:
    给定一个有向图,输入一些边,问最少添加几条边能使整个图强连通
    输入:数据组数T;第一行n和m,n个点,m个边;之后m行每行输入两个整数表示一条有向边
    输出:需要增加边的数量
    分析:
    既然是关于强连通,那么对于本来已经强连通的部分就没必要考虑了,也就是说先要索点。之后的图一定是若干个DAG图,求出每个图的入度和出度为零的点的个数,取最大值即可
    关键:
    特例要想到,如果本来就已经强连通,那么结果应该为0(按照上述算法结果为1)

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cctype>
#include <cmath>
#include <time.h>

using namespace std;

const int maxm=50010;
const int maxn=20010;

struct Edge{
    int to,next;
}edge[maxm<<1];

int nedge,sum,dep,top,n,m,cnt;
int head[maxn],dfn[maxn],stack[maxm],low[maxm],od[maxm],vis[maxm],id[maxm];
int belong[maxn];

void tarjan(int u)
{
    dfn[u]=low[u]=++dep;
    stack[top++]=u;
    vis[u]=1;
    for (int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].to;
        if (!dfn[v])
        {
            tarjan(v);
            low[u]=min(low[u],low[v]);
        }
        else
        {
            if (vis[v]) low[u]=min(low[u],dfn[v]);
        }
    }
    int j;
    if (dfn[u]==low[u])
    {
        sum++;
        do{
            j=stack[--top];
            belong[j]=sum;
            vis[j]=0;
        }while (u!=j);
    }
}

void add_edge(int a,int b)
{
    edge[++nedge].to=b;
    edge[nedge].next=head[a];
    head[a]=nedge;
}

int main()
{
    int cas;
    cin>>cas;
    while (cas--)
    {
        nedge=0;
        memset(head,-1,sizeof(head));
        memset(dfn,0,sizeof(dfn));
        memset(od,0,sizeof(od));
        memset(id,0,sizeof(id));
        memset(vis,0,sizeof(vis));
        memset(belong,0,sizeof(belong));
        sum=0,dep=0,top=0,cnt=0;
        cin>>n>>m;
        for (int i=1;i<=m;i++)
        {
            int a,b;
            cin>>a>>b;
            add_edge(a,b);
        }
        for (int i=1;i<=n;i++)
        {
            if (!dfn[i]) tarjan(i);
        }
        if (sum==1)
        {
            printf("0\n");
        }

        //找入度出度为0点的个数
        else
        {
            for (int i=1;i<=n;i++)
            {
                for (int j=head[i];j!=-1;j=edge[j].next)
                {
                    int v=edge[j].to;
                    if (belong[i]!=belong[v]) od[belong[i]]++,id[belong[v]]++;
                }
            }
            int idnum=0,odnum=0;
            for (int i=1;i<=sum;i++)
            {
                if (id[i]==0) idnum++;
                if (od[i]==0) odnum++;
            }
            int ans=max(idnum,odnum);
            printf("%d\n",ans);
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值