连续高精加

连续高精加

时间限制: 1 Sec 内存限制: 128 MB

题目描述

对给所给的若个个数值,计算出他们的总和

Input

每行数据代表一个加数

Output

输出所有加数的总和

Sample Input

1
1
1
1

Sample Output

4

分析:我们只需要把高静加放在一个函数里,然后每次调用即可

#include<iostream>
#include<cstring>
using namespace std;
string s[6666],ans;
inline string add(string str1,string str2) {
    string str;
    int len1=str1.length();
    int len2=str2.length();
    if(len1<len2) {
        for(int i=1;i<=len2-len1;i++)
            str1="0"+str1;
    }
    else {
        for(int i=1;i<=len1-len2;i++)
            str2="0"+str2;
    }
    len1=str1.length();
    int cf=0,temp;
    for(int i=len1-1;i>=0;i--) {
        temp=str1[i]-'0'+str2[i]-'0'+cf;
        cf=temp/10; temp%=10;
        str=char(temp+'0')+str;
    }
    if(cf) str=char(cf+'0')+str;
    return str;
}
int main() {
    int cnt=0;
    while(cin>>s[++cnt]);
    for(int i=1;i<=cnt;i++) {
        ans=add(ans,s[i]);
    }
    cout<<ans;
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值