题目
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
错误答案
#include <iostream>
#include <cmath>
#include <algorithm>
struct point{
double x, y;
};
bool cmp(point a, point b) {
if(a.x != b.x)
return a.x < b.x;
else
return a.y > b.y;
}
using namespace std;
int main() {
int n;
double d;
int xu = 1;
int ans = -1;
while(cin >> n >> d) {
ans = -1;
if(n == d && n == 0)
break;
point* m = new point[n];
for(int i = 0; i < n; ++i)
cin >> m[i].x >> m[i].y;
sort(m, m + n, cmp);
point heart;
heart.x = m[0].x + sqrt(d * d - m[0].y * m[0].y);
heart.y = 0;
if(m[0].y > d)
;
else {
ans = 1;
for(int i = 1; i < n; ) {
while(pow(m[i].x - heart.x, 2) + pow(m[i].y, 2) <= pow(d, 2) && i < n)
i++;
if(pow(m[i].x - heart.x, 2) + pow(m[i].y, 2) > pow(d, 2)) {
if(m[i].y > d) {
ans = -1;
break;
}
else {
heart.x = m[i].x + sqrt(d * d - m[i].y * m[i].y);
heart.y = 0;
ans++;
i++;
}
}
}
}
cout << "Case " << xu++ << ": " << ans << endl;
delete []m;
}
return 0;
}
正确答案
#include <iostream>
#include <algorithm>
#include <cmath>
struct point{
double x,y;
double x1, x2;
}p[1010];
bool cmp(point a, point b) {
if(a.x1 == b.x1)
return a.x2 < b.x2;
else
return a.x1 < b.x1;
}
using namespace std;
int main() {
int n, d;
int Case = 1;
while(cin >> n >> d) {
if(n == d && n == 0)
break;
int ans = 1;
for(int i = 0; i < n; ++i) {
cin >> p[i].x >> p[i].y;
if(p[i].y > d)
ans = -1; //先处理特殊情况,总是忘记
p[i].x1 = p[i].x - sqrt(d * d - p[i].y * p[i].y);
p[i].x2 = p[i].x + sqrt(d * d - p[i].y * p[i].y);
}
if(ans == -1) {
cout << "Case " << Case++ << ": " << ans << endl;
continue;
}
sort(p, p + n, cmp);
for(int i = 1; i < n; ++i) {
if(p[i].x1 <= p[i - 1].x2) {
if(p[i].x1 < p[i - 1].x2)
p[i].x1 = p[i - 1].x2;
if(p[i - 1].x2 < p[i].x2)
p[i].x2 = p[i - 1].x2;
}
else
ans++;
}
cout << "Case " << Case++ << ": " << ans << endl;
}
return 0;
}