PAT 甲级1001 A+B Format (20分)

题目描述:

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

输入样例:

-1000000 9

输出样例:

-999,991

我的思路:

给出的数据都在int的范围内,故先直接计算出结果,再用字符串进行处理。注意0、负数、逗号的特殊处理。
负数:先保存符号,将数变为其相反数之后在处理
0:直接输出0即可
逗号:从右往左数,每三个数字一个逗号,且数字最前边无逗号

我的代码:

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

string numToStr(int ans){
	string temp,answer;
	if(ans<0){//若结果为负数,变为其相反数,存储逗号
		ans=-ans;
		temp='-';
	}else if(ans==0){//结果为0,直接输出0
		answer='0';
		return answer;
	}
	int cnt=0;//记录当前是第几位
	while(ans){
		cnt++;
		answer+=ans%10+'0';
		ans/=10;
		if(cnt%3==0&&ans!=0){//最前边不能有逗号
			answer+=',';
		}
	}
	//answer中高位存储结果的低位,故需将其反转
	reverse(answer.begin(),answer.end());
	return temp+answer;//若为负数,temp='-',若为正数,temp为空
}

int main(){
	int a,b;
	string answer;
	cin>>a>>b;
	int ans=a+b;
	answer=numToStr(ans);
	cout<<answer;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值