A+B Format (20分)

1001 A+B Format (20分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​ ≤a,b≤10​6​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目解释:
给出两个不同的数字A和B,其中A、B都在int范围之内,将他们相加,并按照标准格式输出。即从每隔三位输出一个逗号,这符合科学计数的模式。

解题思想:
1)因为A和B相加不会溢出,因此直接相加;
2)将相加之后的和转换为字符串,由此得到和的长度;
3)以样例为例,-999991,下标位置从左到右依次是0-1-2-4-5-6,字符串长度为7,每三位输出一个逗号,因此,对下标和长度取余数,余数相等的位置就是输出逗号的位置。

代码:

//1001 A+B Format (20分)
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
	int a, b, c;
	scanf("%d %d", &a, &b);
	string ans = to_string(a + b);
	int len = ans.length();
	for(int i=0; i<len; i++)
	{
		printf("%c",ans[i]);
		if(ans[i] == '-')
			continue;
		if((i+1)%3 == len%3 && i <len-1)
			printf(",");
	}
	return 0;
}

输出结果:
在这里插入图片描述

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值