7-32 Reversing Linked List (25分)输出时翻转

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

给出的数据未必都是链表中结点(有一个点卡),所以先梳理一遍确认链表的结点个数,然后每k个一反转,注意首尾相接。

跟重排链表很像,仅输出不同,因此我就仅输出时翻转了
很多人都是真的翻转了,有个大佬用的数组的reverse,周期为k,我觉得挺方便的,附链接
https://blog.csdn.net/feng_zhiyu/article/details/82254543

我的代码

#include <bits/stdc++.h>
#define pb push_back
#define mem(a,b) memset(a,b,sizeof a)
using namespace std;
typedef long long ll;
const int MAXN=100010,INF=0x3f3f3f3f;
struct node
{
	int add,data,next;
}link[MAXN];
int main()
{
//	freopen("D:\\LYJ.txt","r",stdin);
	int ss,n,k;
	vector<int> vi;
	cin>>ss>>n>>k;
	for(int i=0;i<n;i++)
	{
		int x;
		cin>>x;
		cin>>link[x].data;
		cin>>link[x].next;
		link[x].add=x;
	}
	while(ss!=-1)
	{
		vi.pb(ss);
		ss=link[ss].next;
	}
	int j,f=0;
	for(j=1;j*k<=vi.size();j++)//之前少一个= 
	{
		for(int i=0;i<k;i++)
		{
			if(0==f) printf("%05d %d ",vi[j*k-i-1],link[vi[j*k-i-1]].data);
			else printf("%05d\n%05d %d ",vi[j*k-i-1],vi[j*k-i-1],link[vi[j*k-i-1]].data);
			f++;
		}
			
	}
	for(int i=(j-1)*k;i<vi.size();i++)
	{
		printf("%05d\n%05d %d ",vi[i],vi[i],link[vi[i]].data);
	}
	cout<<"-1";
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值