Backward Digit Sums-POJ - 3187 -枚举-穷竭搜索

Backward Digit Sums
FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this:
3 1 2 4
4 3 6
7 9
16
Behind FJ’s back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ’s mental arithmetic capabilities.
Write a program to help FJ play the game and keep up with the cows.
Input
Line 1: Two space-separated integers: N and the final sum.
Output
Line 1: An ordering of the integers 1…N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
Sample Input
4 16
Sample Output
3 1 2 4
Hint
Explanation of the sample:
There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

题意:给出数列的个数n,和按照题目要求求出的总和,求出字典序最小的该数列
解题思路:直接暴力枚举

AC代码:
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<queue>
#include<string>
#include<sstream>
#include<cmath>
#define maxn 10000000005
using namespace std;
int main()
{
    int n,s,a[15],b[15][15];
    cin>>n>>s;
    for(int i=0;i<10;i++)
        a[i]=i+1; 
    memset(b,0,sizeof(b));
    b[0][0]=1;
    for(int i=1;i<10;i++)  //通过规律把i个数时,下标为j的数对应的系数保存在数组中
    {
        for(int j=0;j<=i;j++)
        {
            if(j==0)
                b[i][j]=1;
            else
                b[i][j]=b[i-1][j]+b[i-1][j-1];
        }
    }
    do  
    {
        int sum=0;
        for(int i=0;i<n;i++)
            sum+=a[i]*b[n-1][i];
        if(sum==s)
        {
            for(int i=0;i<n;i++)
                printf("%d%c",a[i],i==n-1?'\n':' '); //最后一个输出分行,其余输出空格
            break;
        }
    }while(next_permutation(a,a+n)); //通过函数枚举n个数的全排列
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Starry~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值