杭电2006年计算机复试真题第二题(HDU ACM 1002)

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 580794 Accepted Submission(s): 110569

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L

#include "iostream"
#include "string"
using namespace std;

int main(void) {
	string a,b;
	string ans;
	int cnt;
	cin>>cnt;
	int index=1;
	while(cnt--){
		cin>>a>>b;
		int i=a.size()-1;
		int j=b.size()-1;
		bool ci=false;
		ans.clear(); 
		while(i>=0&&j>=0){
			int now=a[i]-'0'+b[j]-'0';
			if(ci)now+=1;
			if(now>=10){
				ci=true;
				now-=10;
			}else{
				ci=false;
			}
			ans+=to_string(now);
			i--;j--;
		}
		while(i>=0){
			int now=a[i]-'0';
			if(ci)now+=1;
			if(now>=10){
				ci=true;
				now-=10;
			}else{
				ci=false;
			}
			ans+=to_string(now);
			i--;
		}
		while(j>=0){
			int now=b[j]-'0';
			if(ci)now+=1;
			if(now>=10){
				ci=true;
				now-=10;
			}else{
				ci=false;
			}
			ans+=to_string(now);
			j--;
		}
		if(ci)ans+='1';
		printf("Case %d:\n",index);
		cout<<a<<" + "<<b<<" = ";
		for(auto x=ans.rbegin();x!=ans.rend();x++){
			cout<<*x;
		}
		
		if(cnt!=0){
			cout<<endl<<endl;
		}else{
			cout<<endl;
		}
		index++;
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值