【PAT】甲级1028 List Sorting (25 分)

【PAT】甲级1028 List Sorting (25 分)

题目

Input Specification:
Each input file contains one test case. For each case, the first line contains two integers N (≤10
5
) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

测试用例

Sample Input 1:
	3 1
	000007 James 85
	000010 Amy 90
	000001 Zoe 60
Sample Output 1:
	000001 Zoe 60
	000007 James 85
	000010 Amy 90

题解

#include<bits/stdc++.h>
using namespace std;

int n,c;  // 总共输入三行

// 定义学生信息结构体
struct NODE
{
    int no;
    string name;
    int score;
};

int cmp(NODE a, NODE b)
{
    if(c == 1)
    {
        return a.no < b.no;// 从小到大顺序
    }
    else if(c == 2)
    {   // If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
        if(a.name != b.name)
        {
            return a.name < b.name;
        }
        else{
            return a.no < b.no;
        }
    }
    else if(c == 3){
        if(a.score != b.score)
        {
            return a.score < b.score;
        }
        else{
            return a.no < b.no;
        }
    }
}

int main()
{
    cin>>n>>c;
    vector<NODE> node(n); // 定义一个数组存储三个学生的结构体

    // 读入学生信息
    for(int i = 0; i < n; i++)
    {
        cin>>node[i].no>>node[i].name>>node[i].score;
    }

    // 排序  注意第三个参数:定义排序的规则
    sort(node.begin(),node.end(),cmp);

    for(int i = 0; i < n; i++)
    {
        printf("%06d %s %d\n",node[i].no,node[i].name.c_str(),node[i].score);
    }

    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

少写代码少看论文多多睡觉

求打赏,求关注,求点赞

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值