PAT甲级 1087 All Roads Lead to Rome (30 分)

5 篇文章 0 订阅
3 篇文章 0 订阅

Indeed there are many different tourist routes from our city to Rome. You are supposed to find your clients the route with the least cost while gaining the most happiness.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2≤N≤200), the number of cities, and K, the total number of routes between pairs of cities; followed by the name of the starting city. The next N−1 lines each gives the name of a city and an integer that represents the happiness one can gain from that city, except the starting city. Then K lines follow, each describes a route between two cities in the format City1 City2 Cost. Here the name of a city is a string of 3 capital English letters, and the destination is always ROM which represents Rome.

Output Specification:

For each test case, we are supposed to find the route with the least cost. If such a route is not unique, the one with the maximum happiness will be recommanded. If such a route is still not unique, then we output the one with the maximum average happiness -- it is guaranteed by the judge that such a solution exists and is unique.

Hence in the first line of output, you must print 4 numbers: the number of different routes with the least cost, the cost, the happiness, and the average happiness (take the integer part only) of the recommanded route. Then in the next line, you are supposed to print the route in the format City1->City2->...->ROM.

Sample Input:

6 7 HZH
ROM 100
PKN 40
GDN 55
PRS 95
BLN 80
ROM GDN 1
BLN ROM 1
HZH PKN 1
PRS ROM 2
BLN HZH 2
PKN GDN 1
HZH PRS 1

结尾无空行

Sample Output:

3 3 195 97
HZH->PRS->ROM

结尾无空行

思路:dijkstra+dfs,名字用map哈希一下就行了

#include <bits/stdc++.h>
using namespace std;
const int maxv=210;
const int inf=1e9;
string st,ed="ROM";
int n,k,mosthappiness=0,pathcnt=0;
double maxavg=0;
int happiness[maxv],g[maxv][maxv],d[maxv];
vector<int> pre[maxv];
vector<int> temp,path;
unordered_map<string,int> nametoint;
unordered_map<int,string> inttoname;
bool vis[maxv];
void Dijkstra(int s)
{
    fill(d,d+maxv,inf);
    memset(vis,false,sizeof(vis));
    d[s]=0;
    for(int i=0;i<n;i++)
    {
        int u=-1,minv=inf;
        for(int j=0;j<n;j++)
        {
            if(!vis[j]&&d[j]<minv)
            {
                u=j;
                minv=d[j];
            }
        }
        if(u==-1) return;
        vis[u]=true;
        for(int v=0;v<n;v++)
        {
            if(!vis[v]&&g[u][v]!=inf)
            {
                if(d[u]+g[u][v]<d[v])
                {
                    d[v]=d[u]+g[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                }
                else if(d[u]+g[u][v]==d[v]) pre[v].push_back(u);
            }
        }
    }
}
void DFS(int v)
{
    if(v==nametoint[st])
    {
        pathcnt++;
        temp.push_back(v);
        int sumhappiness=0;
        for(int i=0;i<temp.size();i++) sumhappiness+=happiness[temp[i]];
        double avg=sumhappiness*1.0/(temp.size()-1);
        if(sumhappiness>mosthappiness)
        {
            mosthappiness=sumhappiness;
            maxavg=avg;
            path=temp;
        }
        else if(sumhappiness==sumhappiness&&avg>maxavg)
        {
            maxavg=avg;
            path=temp;
        }
        temp.pop_back();
        return;
    }
    temp.push_back(v);
    for(int i=0;i<pre[v].size();i++) DFS(pre[v][i]);
    temp.pop_back();
}
int main()
{
    fill(g[0],g[0]+maxv*maxv,inf);
    fill(happiness,happiness+maxv,0);
    cin>>n>>k>>st;
    nametoint[st]=0;
    inttoname[0]=st;
    for(int i=1;i<=n-1;i++)
    {
        string name;
        int happy;
        cin>>name>>happy;
        nametoint[name]=i;
        inttoname[i]=name;
        happiness[nametoint[name]]=happy;
    }
    for(int i=0;i<k;i++)
    {
        string a,b;
        int cost;
        cin>>a>>b>>cost;
        g[nametoint[a]][nametoint[b]]=g[nametoint[b]][nametoint[a]]=cost;
    }
    Dijkstra(0);
    DFS(nametoint[ed]);
    printf("%d %d %d %d\n",pathcnt,d[nametoint[ed]],mosthappiness,(int)maxavg);
    for(int i=path.size()-1;i>=0;i--)
    {
        cout<<inttoname[path[i]];
        if(i!=0) printf("->");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值