PAT甲级 1103 Integer Factorization(30分)

5 篇文章 0 订阅

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122+42+22+22+12, or 112+62+22+22+22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1​,a2​,⋯,aK​ } is said to be larger than { b1​,b2​,⋯,bK​ } if there exists 1≤L≤K such that ai​=bi​ for i<L and aL​>bL​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

思路:直接DFS就可以了,注意相同因子是可以重复选的

#include <bits/stdc++.h>
using namespace std;
const int maxv=410;
int n,k,p,maxsum=0;
vector<int> factor;
vector<int> temp,ans;
void DFS(int sum,int st,int cnt,vector<int> &factor,vector<int> &temp)
{
    if(sum==n&&cnt==k)
    {
        int tempsum=accumulate(temp.begin(),temp.end(),0);
        if(tempsum>maxsum)
        {
            ans=temp;
            maxsum=tempsum;
        }
        return;
    }
    else if(sum>n||cnt>k) return;
    for(int i=st;i<factor.size();i++) //对于每个因子,有选和不选两种状态
    {
        temp.push_back(factor[i]);//选
        sum+=pow(factor[i],p);
        DFS(sum,i,cnt+1,factor,temp);//可以重复选
        sum-=pow(factor[i],p);//不选
        temp.pop_back();

    }
}
int main()
{
    scanf("%d %d %d",&n,&k,&p);
    for(int i=1;i*i<=n;i++) factor.push_back(i);
    sort(factor.begin(),factor.end(),greater<int>());
    DFS(0,0,0,factor,temp);
    if(maxsum==0)
    {
        printf("Impossible");
        return 0;
    }
    printf("%d = ",n);
    for(int i=0;i<ans.size();i++)
    {
        printf("%d^%d",ans[i],p);
        if(i!=ans.size()-1) printf(" + ");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值