ZOJ 2019校赛 J Extended Twin Composite Number

157 - The 19th Zhejiang University Programming Contest Sponsored by TuSimple (Mirror) - J Extended Twin Composite Number

Time Limit: 1 Second Memory Limit: 65536 KB Special Judge

Do you know the twin prime conjecture? Two primes and are called twin primes if . The twin prime conjecture is an unsolved problem in mathematics, which asks for a proof or a disproof for the statement “there are infinitely many twin primes”.

On April 17, 2013, Yitang Zhang announced a proof that for some integer that is less than 70 million, there are infinitely many pairs of primes that differ by . As of April 14, 2014, one year after Zhang’s announcement, the bound has been reduced to 246. People are hoping for the bound to be smaller and smaller, so that a proof for the conjecture can finally be found.

For our dear contestants, we’ve prepared another similar problem for you, which is the extended twin composite number problem: Given a positive integer , find two integers and such that and both and are composite numbers.

Input

There are multiple test cases. The first line of the input contains an integer (about ), indicating the number of test cases. For each test case:

The only line contains one integer ().

Output

For each test case output two integers in one line, indicating and where . If there are multiple valid answers, you can print any of them; If there is no valid answer, output ``-1’’ (without quotes) instead.

Sample Input

3
11
1805296
5567765

Sample Output

4 15
114514 1919810
111234 5678999

大声bb

题目里说了任意一组满足条件的解都可以
再一看数据也不是很大(没爆long long)也许吧,我乱说的
直接乘8乘9就完事了

#include<bits/stdc++.h>
#include <iostream>
#include<string>
#include<cmath>
typedef long long ll;
using namespace std;

int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		ll temp;
		scanf("%lld",&temp);
		ll x=temp*8;
		ll y=temp*9;
		printf("%lld %lld\n",x,y);
	}
    return 0;
}
 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值