Arbitrage POJ - 2240(bellman_ford 判断正权环)

题目

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.
Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

解释

题目判断是否存在套汇,也就是是否存在自减环。可以借助bellman_ford,将更新条件改成相乘,初始化某一点为1,其余为0.注意该环由于是套汇要回到原点,松弛次数n-1次.由常见的终点回到原点的这一次,相当于终点变成了起点,多了一次松弛机会。相当于如果同一条边松弛了超过等于n次,就代表存在环。注意边的条数并不是完全图的最大条数,可以更大,重边。
该题目也可以用floyd来做,初始化所有自己到自己为1,其余为0,然后存下剩余边到邻接矩阵。更新完后,如果自己到自己有大于1的,则存在套汇。

#include <cstdio>
#include <string>
#include <vector>
#include <map>
#include <iostream>
using namespace std;
map<string,int> p;
struct Edge{
	int u, v;
	double w;
	Edge(int _u, int _v, double _w):u(_u),v(_v),w(_w){}
};
vector<Edge> a;
int n, m;
int bellman_ford(){
	double dis[31];
	for (int i = 0; i < n; i++){
		dis[i] = 0;
	}
	dis[0] = 1;
	int flag;
	for (int i = 0; i < n-1; i++){
		flag = 1;
		for (int j = 0; j < m; j++){
			if(dis[a[j].v] < dis[a[j].u] * a[j].w){
				dis[a[j].v] = dis[a[j].u] * a[j].w;
				flag = 0;
			}
		}
		if(flag)
			return 0;
	}
	flag = 0;
	for (int j = 0; j < m; j++){
			if(dis[a[j].v] < dis[a[j].u] * a[j].w){
				dis[a[j].v] = dis[a[j].u] * a[j].w;
				flag = 1;
			}
		}
	if(flag)
		return 1;
	return 0;
}
int main(){
	double w;
	string s, ss;
	int cont = 1;
	while (~scanf("%d", &n) && n){
		for (int i = 0; i < n; i++){
			cin >> s;
			p[s] = i; 
		}
		cin >> m;
		a.clear();
		for (int i = 0; i < m; i++){
			cin >> s >> w >> ss;
			a.push_back(Edge(p[s],p[ss], w));
		} 
		p.clear();
		printf("Case %d: ", cont++);
		if (bellman_ford())
			cout <<"Yes"<<endl;
		else
			cout <<"No"<<endl;		
	}
	
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值