完全背包(求超过一定重量的最小花费)

Dawn-K recently discovered a very magical phenomenon in the supermarket of Northeastern University: The large package is not necessarily more expensive than the small package.

On this day, Dawn-K came to the supermarket to buy mineral water, he found that there are nn types of mineral water, and he already knew the price pp and the weight cc (kg) of each type of mineral water. Now Dawn-K wants to know the least money aa he needs to buy no less than mm kilograms of mineral water and the actual weight bb of mineral water he will get. Please help him to calculate them.

Input
The input consists of multiple test cases, each test case starts with a number nn (1 \le n \le 10^31≤n≤10
3
) – the number of types, and mm (1 \le m \le 10^41≤m≤10
4
) – the least kilograms of water he needs to buy. For each set of test cases, the sum of nn does not exceed 5e45e4.

Then followed n lines with each line two integers pp (1 \le p \le 10^91≤p≤10
9
) – the price of this type, and cc (1 \le c \le 10^41≤c≤10
4
) – the weight of water this type contains.

Output
For each test case, you should output one line contains the minimum cost aa and the weight of water Dawn-K will get bb. If this minimum cost corresponds different solution, output the maximum weight he can get.

(The answer aa is between 11 and 10^910
9
, and the answer bb is between 11 and 10^410
4
)

样例输入 复制
3 3
2 1
3 1
1 1
3 5
2 3
1 2
3 3
样例输出 复制
3 3
3 6

#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long 
const int inf = 0x3f3f3f3f;
using namespace std;
int dp[10001];
int w[1001];
int v[1001];
int main(){
	int n, m, i, j;
	while(~scanf("%d %d", &n, &m)){
		for(i = 1; i <= n; i++)
			scanf("%d %d", &v[i], &w[i]);
		memset(dp, inf, sizeof(dp));
		dp[0] = 0;
		for(i = 1; i <= n; i++)
			for(j = 0; j <= 10000; j++){
				if(j >= w[i])
					dp[j] = min(dp[j], dp[j-w[i]]+v[i]);
			}
		int ans = dp[m];
		int k = m;
		for(i = m+1; i <= 10000; i++){
			if(ans >= dp[i]){
				ans = dp[i];
				k = i;
			}
		}
		printf("%d %d\n", ans, k);
	}	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值