过几天后是星期几

  • 题目描述

    It's Saturday today, what day is it after 1^1 + 2^2 + 3^3 + ... + N^N days?

  • 输入

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case: There is only one line containing one integer N (1 <= N <= 1000000000).

  • 输出

    For each test case, output one string indicating the day of week.

样例输入

2
1
2

样例输出

Sunday
Thursday

(可用费马小定理) 

#include <iostream>
#include <stdio.h>
using namespace std;
string ans2[]={"Saturday","Sunday","Monday", "Tuesday", "Wednesday", "Thursday", "Friday" };
int qm(int a,int b)  //快速幂取模
{
    int r=1;
    while(b)
    {
        if(b&1)
        {
            r=((r%7)*(a%7))%7;
        }
        a=((a%7)*(a%7))%7;
        b>>=1;
    }
    return r;
}
int main()
{
    int x[400],c=0,n;
    long long k;
    for(int i=1;i<300;i++)
    {
        c+=qm(i,i);
        x[i]=(c%7);
    }
    scanf("%d",&n);
    while(n--)
    {
        scanf("%lld",&k);
        k=k%294;
        cout<<ans2[x[k]]<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值