Floyd-poj1847

题目
Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.
Input
The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.
Output
The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.
Sample Input
3 2 1
2 2 3
2 3 1
2 1 2
Sample Output
0
题意:输入三个数N,A,B,N代表交叉点数(就是结点数),求A->B需要转换开关次数,没有路径输出-1;
然后输入N行数据:假设第i行数据为:2 1 3;
代表的是第i个结点可以到达其他2个结点,分别是1和3,默认情况下只能是i->1,但是
i->3之间存在路,如果需要走i->3的话就需要转换一次开关。
思路:题目差不多就是上述这个意思,在邻接矩阵全部初始化为最大值前提下,我们将默认道路标记为0(意思是不需要转开关),存在的道路标记为1(需要转换开关),计算A->B的最短路径,如果等于0x3f则输出-1,否则输出最短路径。

见代码

#include<cstdio>
#include<iostream>
#include<vector> 
#include<string.h>
using namespace std;
int N,A,B,map[110][110];
void floyd(int n)
{
	for(int k=1;k<=N;k++)
	{
		for(int i=1;i<=N;i++)
		{
			for(int j=1;j<=N;j++)
			{
				map[i][j]=min(map[i][j],map[i][k]+map[k][j]);
			}
		}
	}
}
int main()
{
	scanf("%d%d%d",&N,&A,&B);
	memset(map,0x3f,sizeof(map));//之前这里我给初始化成了1<<29,然后一直错,我吐了 
	int temp,num;
	for(int i=1;i<=N;i++)//初始化 
	{
		map[i][i]=0; 
		scanf("%d",&temp);
		for(int j=1;j<=temp;j++)
		{
			scanf("%d",&num);
			if(j==1)
			{
				map[i][num]=0;
			}
			else
				map[i][num]=1;		
		}
	}
	floyd(N);
	if(map[A][B]>=0x3f)
	{
		cout<<"-1"<<endl;
	}
	else
		cout<<map[A][B]<<endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值