Arbitrage
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 26618 | Accepted: 11223 |
Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
Sample Output
Case 1: Yes Case 2: No
题意;每两种货币之间有一种汇率 给定货币种类与汇率 问一种货币能否经过兑换后价值增大
#include<iostream>
#include<cstring>
using namespace std;
double rate[100][100];
//string name[35];
char name[35][100];
int n,m;
int get(char nname[])
{
for(int i=1;i<=n;i++)
// if(name[i]==nname) return i;
if(strcmp(name[i],nname)==0) return i;
}
bool floyd()
{
int i,j,k;
for(k=1;k<=n;k++)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(rate[i][k]*rate[k][j]>rate[i][j])
rate[i][j]=rate[i][k]*rate[k][j];
}
}
}
for(i=1;i<=n;i++)
if(rate[i][i]>1) return true;
return false;
}
int main()
{
double rrate;
//string name1,name2;
char name1[100],name2[100];
int cases=0;
while(cin>>n&&n)
{
cases++;
memset(rate,0,sizeof(rate));
for(int i=1;i<=n;i++) cin>>name[i];
cin>>m;
for(int i=1;i<=m;i++)
{
cin>>name1>>rrate>>name2;
int u=get(name1);
int v=get(name2);
rate[u][v]=rrate;
// cout<<u<<v<<endl;
}
if(floyd()) cout<<"Case "<<cases<<": "<<"Yes"<<endl;
else cout<<"Case "<<cases<<": "<<"No"<<endl;
}
return 0;
}
(用string会超时 ,改为char则可以通过)