杭电 1072 Nightmare(题解+代码)

题目传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1072
题目:

Nightmare
Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1.We can assume the labyrinth is a 2 array.
2.Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3.If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
4.If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
5.A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6.The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius’ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius’ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4 
1 0 0 0 1 0 0 1 
1 4 1 0 1 1 0 1 
1 0 0 0 0 3 0 1 
1 1 4 1 1 1 1 1

Sample Output

4
-1
13

题意:Ignatius昨天做了个噩梦,发现自己在一个迷宫里,并且身上绑了一个定时炸弹,炸弹初始时间为6分钟。他需要在炸弹爆炸之前离开迷宫。Ignatius每移一格需要一分钟,他可以朝上下左右四个方向移动。在迷宫的某些地方有炸弹重置装置,可以重置炸弹的时间到6分钟。需要注意的是,当到达炸弹重置装置的位置时,如果炸弹时间为0则不可以重置炸弹时间;同样的,如果到达终点的时候,炸弹时间为0,则无法逃离迷宫。如果他可以逃离迷宫的话,输出所花费的时间,否则输出-1。
题解:bfs题目,需要注意的是,走过的格子可以再走的,只需要标记走过的炸弹重置装置的位置。
代码及注释如下:

#include<iostream>
#include<cstring>
#include<queue> 
#define INF 99999999
using namespace std;
int map[105][105],ans,vis[105][105],sx,sy,ex,ey,n,m;
struct node {
	int x,y,step,time;
};
bool bfs(int x, int y) {
	queue<node> q;
	q.push(node{x,y,0,6});//结构体的技巧 
	int next[4][2]={1,0,0,1,-1,0,0,-1};
	while(!q.empty()) {
		node tmp=q.front();
		q.pop();
		if(tmp.x==ex&&tmp.y==ey) {
			ans=tmp.step;
			return true;
		}
		if(tmp.time<=1) continue;//过滤掉到达下一个点,炸弹为零的情况 
		for(int i=0;i<4;i++) {
			int tx=tmp.x+next[i][0];
			int ty=tmp.y+next[i][1];
			if(tx<1||tx>n||ty<1||ty>m||!map[tx][ty]||vis[tx][ty]) continue;
			if(map[tx][ty]==4) {
				vis[tx][ty]=1;//只标记重置炸弹的位置
				q.push(node{tx,ty,tmp.step+1,6});
			}
			else q.push(node{tx,ty,tmp.step+1,tmp.time-1});
		}
	}
	return false;
}
int main() {
	int t;
	cin>>t;
	while(t--) {
		cin>>n>>m;
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=n;i++)
			for(int j=1;j<=m;j++) {
				cin>>map[i][j];
				if(map[i][j]==2) sx=i,sy=j;//起始点 
				if(map[i][j]==3) ex=i,ey=j;//终点 
			}
		if(bfs(sx,sy)) cout<<ans<<endl;
		else cout<<"-1"<<endl;
	}
	return 0;
} 

ac图片

  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值