poj1797 Heavy Transportation(Dijkstra变形)

                                                Heavy Transportation

Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 65111 Accepted: 16022

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题目大意是一个复杂的道路网上,道路的载重能力有限,让你找出从起点到终点所有连通的道路中载重能力最大的那条道路的载重值,即求出所有连通的道路中每一个路段的最小值的最大值,这里使用的是Dijkstra算法的变形,我们使用weight数组来表示从起点到其他点的最大载重能力  当满足 min(weight[u],mp[u][j])>weight[j] 时 即可以更新weight[j]=min(weight[u],mp[u][j]);

还有一个类似的求路段最小的最大值问题:Poj2253Frogger

参考的blog:https://blog.csdn.net/qq_44786250/article/details/104208774

需要注意和普通最短路算法的区别   注意初始化为-inf

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int mm=1e3+10;

int mp[mm][mm];
int weight[mm];//储存路径上最小值的最大值 
int t,n,m;
int s,e,d;

void dijkstra(){
	int book[mm]={0};
	for(int i=1;i<n;i++){
		int maxx=-inf;
		int u;
		for(int j=1;j<=n;j++)
			if(book[j]==0&&weight[j]>maxx){
				maxx=weight[j];
				u=j;
			}
		book[u]=1;
		for(int j=1;j<=n;j++)
			if(book[j]==0&&min(weight[u],mp[u][j])>weight[j])
				weight[j]=min(weight[u],mp[u][j]);
	}	
} 

int main()
{
	cin>>t;
	for(int k=1;k<=t;k++){
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
				mp[i][j]=i==j?0:-inf;
		while(m--){
			scanf("%d%d%d",&s,&e,&d);
			mp[s][e]=mp[e][s]=d;
		}
		for(int i=1;i<=n;i++)
			weight[i]=mp[1][i];
			
		dijkstra();
		printf("Scenario #%d:\n",k);
		printf("%d\n\n",weight[n]);
	}	
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值