poj2253---Frogger (最短路变形)一只快乐的小青蛙

                                                              Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 76896 Accepted: 23403

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

已知湖里有两只青蛙,位置分别是 1和 2 由于湖水的原因他们不能游泳,只能通过其他的石头作为垫脚石,跳过去找到他们梦寐以求的情侣,需要我们找到两个石头之间 可以连通的路径中青蛙最大的单次跳跃距离最小,就是一个也是一个木桶短板效应,求得路径上最小的最大距离

根据题意可以知道青蛙的最大跳跃距离并不受限制,即任意两个石头之间是相通的,因此可以不需要初始化 邻接矩阵 

这个是求最小的最大距离,还有一个类似的题目是 求最大的最小值问题http://poj.org/problem?id=1797Heavy Transportation

可以参考的blog:https://blog.csdn.net/qq_44786250/article/details/104197223

但是这道题具有更大的优势就是数据量比较小,可以使用暴力的Floyd算法,Dijkstra和SPFA同样绰绰有余

路径更新时不需要更新可达路径,dis数组表示的是从 1 到其他点的符合题目的最大最小距离

提醒:由于G++和C++对精度的要求不一样,导致G++会被WA,反正是使用C++编译器就对了 

Floyd:

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int mm=222;

int n;
double mp[mm][mm];
int x[mm],y[mm];
int t=1; 

int main()
{
	while(scanf("%d",&n)!=EOF&&n){
		for(int i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		for(int i=1;i<=n;i++)
			for(int j=i+1;j<=n;j++)
				mp[i][j]=mp[j][i]=sqrt(double(x[i]-x[j])*(x[i]-x[j])+double(y[i]-y[j])*(y[i]-y[j]));
		//floyd 
		for(int k=1;k<=n;k++)
			for(int i=1;i<=n;i++)
				for(int j=1;j<=n;j++)
					mp[i][j]=min(mp[i][j],max(mp[i][k],mp[k][j]));
										
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",t++,mp[1][2]);
	}


	return 0;
}

Dijkstra:

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int mm=222;

int t=1;
int n,m;
int x[mm],y[mm];
double mp[mm][mm];
double dis[mm];
 
void dijkstra(){
	int book[mm]={0};
	for(int i=1;i<n;i++){
		double mint=inf;
		int u;
		for(int j=1;j<=n;j++)
			if(dis[j]<mint&&book[j]==0){
				u=j;
				mint=dis[j];
			}
		book[u]=1;
		for(int j=1;j<=n;j++)
			if(book[j]==0&&max(mp[u][j],dis[u])<dis[j])
				dis[j]=max(mp[u][j],dis[u]);
	}
} 

int main()
{
	while(scanf("%d",&n)!=EOF&&n){
//		for(int i=1;i<=n;i++)
//			for(int j=1;j<=n;j++)
//				mp[i][j]=i==j?0:inf;
		for(int i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		for(int i=1;i<=n;i++)
			for(int j=i+1;j<=n;j++)
				mp[i][j]=mp[j][i]=sqrt(double(x[i]-x[j])*(x[i]-x[j])+double(y[i]-y[j])*(y[i]-y[j]));
		for(int i=1;i<=n;i++)
			dis[i]=mp[1][i];
		
		dijkstra();
		
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",t++,dis[2]);
	}

	return 0;
}

SPFA

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int mm=222;

int t=1;
int n,m;
int x[mm],y[mm];
double mp[mm][mm];
double dis[mm];

void spfa(){
	int book[mm]={0};
	queue<int>q;
	q.push(1);
	book[1]=1;
	while(!q.empty()){
		int u=q.front();
		q.pop();
		book[u]=0;
		for(int j=1;j<=n;j++)
			if(max(dis[u],mp[u][j])<dis[j]){
				dis[j]=max(dis[u],mp[u][j]);
				if(book[j]==0){
					q.push(j);
					book[j]=1;
				}
			}
	}
}

int main()
{
	while(scanf("%d",&n)!=EOF&&n){
//		for(int i=1;i<=n;i++)
//			for(int j=1;j<=n;j++)
//				mp[i][j]=i==j?0:inf;
		for(int i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		for(int i=1;i<=n;i++)
			for(int j=i+1;j<=n;j++)
				mp[i][j]=mp[j][i]=sqrt(double(x[i]-x[j])*(x[i]-x[j])+double(y[i]-y[j])*(y[i]-y[j]));
		for(int i=1;i<=n;i++)
			dis[i]=i==1?0:inf;//mp[1][i];
		spfa();
		
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",t++,dis[2]);
	} 
	
	return 0; 
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值