这里先说一下整数的数据范围:
int:32位 -2147483648~2147483647。
long long 64位 9223372036854775807
unsigned long long 64位 18446744073709551615 一般在hash的时候用,溢出就相当于取模了
__int128 128位 相对于longlong位数变为原来的2倍了
通过这个函数就可以看出 ll 占用 8个字节 __128占用 16个字节
斐波那契的矩阵运算
1303. 斐波那契前 n 项和
大家都知道 Fibonacci 数列吧,f1=1,f2=1,f3=2,f4=3,…,fn=fn−1+fn−2f1=1,f2=1,f3=2,f4=3,…,fn=fn−1+fn−2。
现在问题很简单,输入 nn 和 mm,求 fnfn 的前 nn 项和 SnmodmSnmodm。
输入格式
共一行,包含两个整数 nn 和 mm。
输出格式
输出前 nn 项和 SnmodmSnmodm 的值。
数据范围
1≤n≤20000000001≤n≤2000000000,
1≤m≤10000000101≤m≤1000000010
输入样例:
5 1000
输出样例:
12
code:
#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
const int N = 3;
int n, m;
void mul(int c[],int a[],int b[][N]){
int temp[N] = {0};
for(int j = 0;j < N; j ++){
for(int k = 0;k < N ;k ++)
{
temp[j] = (temp[j] + (ll)a[k] * b[k][j]) % m;
}
}
//都改变完了在改变f数组
memcpy(c, temp, sizeof temp);
}
void mul(int c[][N],int a[][N], int b[][N]){
int temp[N][N] = {0};//初始化
for(int i =0 ;i < N; i ++){
for(int j = 0;j < N; j++){
for(int k = 0; k < N ;k ++){
temp[i][j] = (temp[i][j] + (ll)a[i][k] * b[k][j]) % m;
}
}
}
memcpy(c, temp, sizeof temp);
}
int main()
{
cin >> n >> m;
int f[N] = {1, 1, 1};
int a[N][N] = {
{0, 1, 0},
{1, 1, 1},
{0, 0, 1}
};
n --;
while(n){
if(n & 1) mul(f, f, a);
mul(a, a, a);
n >>= 1;
}
cout << f[2] << endl;
return 0;
}