【PAT甲级】 1075 PAT Judge 测试点4

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤104), the total number of users, K (≤5), the total number of problems, and M (≤105), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

看了网上的一些帖子,说是测试点4是排名问题,但是我感觉我的排名地方没问题啊,因为不参与排名的我根本就没有排序,有时间的友友们可以帮忙看看我代码哪里有问题么?或者测试用例也行。

#include <iostream>
#include <vector>
#include <map>
#include <queue>
using namespace std;
struct Student
{
    int id, perfectNum = 0, total = 0;
    bool operator<(const Student &p) const
    {
        if (total == p.total)
            if (perfectNum == p.perfectNum)
                return id > p.id;
            else
                return perfectNum < p.perfectNum;
        else
            return total < p.total;
    }
};
int main()
{
    int n, k, m, x, y, z;
    cin >> n >> k >> m;
    // 存满分
    vector<int> Maxium(k + 1);
    for (int i = 1; i < k + 1; i++)
        cin >> Maxium[i];
    vector<Student> students(n + 1);
    vector<vector<int>> arr(n + 1);
    // 假设所有学生开始都不参与排名
    vector<int> visit(n + 1, 0);
    for (int i = 1; i <= n; i++)
        arr[i].resize(k + 1, -1);
    for (int i = 0; i < m; i++)
    {
        cin >> x >> y >> z;
        students[x].id = x;
        if (z == -1)
            arr[x][y] = 0;
        else
        {
            visit[x] = 1; // 存在编译通过的学生则参与排名
            if (arr[x][y] < z)
            {
                arr[x][y] = z;
                if (arr[x][y] == Maxium[y])
                    // 第一次等于满分才++,第二次满分无法通过(arr[x][y] < z)
                    students[x].perfectNum++;
            }
        }
    }
    priority_queue<Student> myQueue;
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= k; j++)
            if (arr[i][j] != -1) // arr[i][j]==-1表示学生i没有对j问题进行提交
                students[i].total += arr[i][j];
        if (visit[i] == 1) // 如果该学生参与排名,则加入到优先队列
            myQueue.push(students[i]);
    }
    int rank = 1, cnt = 1;
    int last = myQueue.top().total;
    while (!myQueue.empty())
    {
        Student student = myQueue.top();
        if (student.total != last)
            rank = cnt;
        printf("%d %05d %d", rank, student.id, student.total);
        for (int i = 1; i <= k; i++)
            if (arr[student.id][i] != -1)
                printf(" %d", arr[student.id][i]);
            else
                printf(" -");
        printf("\n");
        last = student.total;
        myQueue.pop();
        cnt++;
    }
    return 0;
}




看了柳神的代码,发现我正好犯了她说的注意点,说最后一个测试样例是有一个人一开始得到了分数,后来提交了一次没有通过编译器的,按我上面的代码,这个人的分数会被至为0,而不是编译通过那次的分数。

修改如下:则顺利通过测试点4,和我同样测试点4没过的友友们可以参考一下,可能是和我同样的问题,希望对友友有帮助。

//修改前
if (z == -1)
    arr[x][y] = 0;
//修改后
int maxscore = max(arr[x][y], z);
if (maxscore == -1)
    arr[x][y] = 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值