【PAT甲级】 1159 Structure of a Binary Tree

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

我一开始是用一个二维数组存储每一个结点的所有到跟结点路径上的结点(也就是该结点的所有祖先),然后再找x和y的共同祖先来着。提交之后发现内存超限(笑哭)。

后来从其他博主那学到的找LCA的方法:x和y的最近公共祖先一定在中序遍历x的位置和中序遍历y的位置之间,而x和y的公共祖先一定在先序遍历中x和y的位置之前。在先序遍历中从0开始查找,找到的第一个中序遍历位置位于x和y之间的就是最近公共祖先。(x在中序序列中的位置可能在y之前,也可能在y之后)

测试点1:x,y两个数在中序序列中的位置,x在后,y在前。测试点2:x==y,输出printf("%d is an ancestor of %d.\n", x, x);即x是x的祖先。

AC代码:

#include <iostream>
#include <vector>
#include <algorithm>
#include <queue>
#include <unordered_map>
using namespace std;
struct BiNode
{
    int value;
    BiNode *lchild, *rchild, *parent;
} *BiTree;
struct type_int
{
    int number = -1;
};
vector<int> preOrder, inOrder;
BiNode *construct(int pl, int pr, int il, int ir)
{
    if (pl > pr)
        return NULL;
    BiNode *pnode = (BiNode *)malloc(sizeof(BiNode));
    pnode->value = preOrder[pl];
    int pos = find(inOrder.begin(), inOrder.end(), pnode->value) - inOrder.begin();
    pnode->lchild = construct(pl + 1, pl + pos - il, il, pos - 1);
    if (pnode->lchild)
        pnode->lchild->parent = pnode;
    pnode->rchild = construct(pl + pos - il + 1, pr, pos + 1, ir);
    if (pnode->rchild)
        pnode->rchild->parent = pnode;
    return pnode;
}
int main()
{
    int m, n, x = 1, y = 1;
    cin >> m >> n;
    preOrder.resize(n);
    inOrder.resize(n);
    unordered_map<int, type_int> myMap;
    for (int i = 0; i < n; i++)
    {
        cin >> inOrder[i];
        myMap[inOrder[i]].number = i;
    }
    for (int i = 0; i < n; i++)
        cin >> preOrder[i];
    BiTree = construct(0, n - 1, 0, n - 1);
    for (int i = 0; i < m; i++)
    {
        scanf("%d %d", &x, &y);
        int posx = myMap[x].number;
        int posy = myMap[y].number;
        if (posx == -1 && posy == -1)
            printf("ERROR: %d and %d are not found.\n", x, y);
        else if (posx == -1 && posy != -1)
            printf("ERROR: %d is not found.\n", x);
        else if (posy == -1 && posx != -1)
            printf("ERROR: %d is not found.\n", y);
        else
        {
            for (int i = 0; i < n; i++)
            {
                int pos = myMap[preOrder[i]].number;
                if ((posx <= pos && pos <= posy) || (posx >= pos && pos >= posy))
                {
                    if (pos == posx)
                        printf("%d is an ancestor of %d.\n", x, y);
                    else if (pos == posy)
                        printf("%d is an ancestor of %d.\n", y, x);
                    else
                        printf("LCA of %d and %d is %d.\n", x, y, preOrder[i]);
                    break;
                }
            }
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值