HDU-6576 Worker

Worker
HDU-6576

Problem Description

Avin meets a rich customer today. He will earn 1 million dollars if he can solve a hard problem. There are n warehouses and m workers. Any worker in the i-th warehouse can handle ai orders per day. The customer wonders whether there exists one worker assignment method satisfying that every warehouse handles the same number of orders every day. Note that each worker should be assigned to exactly one warehouse and no worker is lazy when working.

In put

The first line contains two integers n (1 ≤ n ≤ 1, 000), m (1 ≤ m ≤ 1018). The second line contains n integers. The i-th integer ai (1 ≤ ai ≤ 10) represents one worker in the i-th warehouse can handle ai orders per day.

Out put
If there is a feasible assignment method, print “Yes” in the first line. Then, in the second line, print n integers with the i-th integer representing the number of workers assigned to the i-th warehouse.
Otherwise, print “No” in one line. If there are multiple solutions, any solution is accepted.

Sample Input
2 6
1 2
2 5
1 2

Sample Output
Yes
4 2
No

思路:
问题就是让每个房间的总贡献度一样的时候,不同的房间应该分多少个人。每个房间总贡献度=人数*一个人在此房间的贡献度(ai)。
那么如果让这所有的房间的贡献度都有一个数能除以他们。就可以满足题意了。那么这个数就是这所有(ai)的最小公倍数。接下来就可以求出每个房间各有多少人。就可以求出所有的人数,如果m%(sum)==0,那么就可以满足题意了。下面上代码
添加链接描述

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll gcd1(ll a,ll b)
{
	if(b==0)
	{
		return a;
	}
	else return gcd1(b,a%b);
}
int main()
{
	ll n,m,a[2000],b[2000],c[2000];
	scanf("%lld%lld",&n,&m);
	for(int i=1;i<=n;i++)
	{
		scanf("%lld",&a[i]);
	}
	for(int i=1;i<=n;i++)
	{
		if(i!=1)
		{
			b[i]=b[i-1]/gcd1(b[i-1],a[i])*a[i];
		}
		else
		{
			b[i]=a[i];
		}
	}
	ll sum=0;
	for(int i=1;i<=n;i++)
	{
		c[i]=b[n]/a[i];
		sum+=c[i];
	}
	if(m%sum!=0)
	{
		printf("NO\n");
	}
	else
	{
		printf("Yes\n");
		for(int i=1;i<=n;i++)
		{
			if(i==1)
			{
				printf("%lld",m/sum*c[i]);
			} 
			else
			{
				printf(" %lld",m/sum*c[i]);
			}
		 } 
		 printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值