实验的注意事项
1、AC使用6605
2、AP使用4050,AP上零配置
3、黄色标记的为注释部分
一、实验拓扑图
在交换机和AC 上进行配置
整体的配置思路
- 在交换机和AC 上创建vlan,添加相应的接口,手动配置AC的ip地址
- 在汇聚交换机2上做vlan间路由
vlan 10 10.1.10.0/24 AP,AC
vlan 11 10.1.11.0/24 SSID:huawei1
vlan 12 10.1.12.0/24 SSID:huawei2
vlan 13 10.1.13.0/24 有线终端PC1
也就是给vlanif配地址,作为vlan的网关
实现vlan间可以互通
- 配置DHCP服务器在交换机2上,让交换机2充当dhcp服务器
- 配置AP上线,在AC上进行配置
- 实现AC给AP下发WLAN业务
在交换机1上配置
[SW1]vlan batch 10 to 13
[SW1]int g0/0/1
[SW1-GigabitEthernet0/0/1]port link-type trunk
[SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan all
[SW1-GigabitEthernet0/0/1]port trunk pvid vlan 10 //将AP的数据帧放入vlan10中,打上vlan10数据帧的标签
[SW1-GigabitEthernet0/0/2]port link-type trunk
[SW1-GigabitEthernet0/0/2]port trunk allow-pass vlan all
[SW1-GigabitEthernet0/0/2]port trunk pvid vlan 10 //将AP的数据帧放入vlan10中,打上vlan10数据帧的标签
[SW1-GigabitEthernet0/0/2]int g0/0/3
[SW1-GigabitEthernet0/0/3]port link-type access
[SW1-GigabitEthernet0/0/3]port default vlan 13 将有线终端pc机加入到vlan13中
[SW1]int g0/0/4
[SW1-GigabitEthernet0/0/4]port link-type trunk
[SW1-GigabitEthernet0/0/4]port trunk allow-pass vlan all
查看vlan端口
[SW1]dis port vlan
Port Link Type PVID Trunk VLAN List
-------------------------------------------------------------------------------
GigabitEthernet0/0/1 trunk 10 1-4094
GigabitEthernet0/0/2 trunk 10 1-4094
GigabitEthernet0/0/3 access 13 -
GigabitEthernet0/0/4 trunk 1 1-4094
交换机2的配置
[SW2]vlan batch 10 to 13
[SW2]int g0/0/3
[SW2-GigabitEthernet0/0/3]port link-type trunk
[SW2-GigabitEthernet0/0/3]port trunk allow-pass vlan all
[SW2-GigabitEthernet0/0/3]int g0/0/1
[SW2-GigabitEthernet0/0/1]port link-type trunk
[SW2-GigabitEthernet0/0/1]port trunk allow-pass vlan all
AC上
[AC6605]vlan batch 10 to 13
[AC6605]int g0/0/1
[AC6605-GigabitEthernet0/0/1]port link-type tr
[AC6605-GigabitEthernet0/0/1]port trunk allow-pass vlan all
交换机2上
[SW2]int vlan 10
[SW2-Vlanif10]di this
interface Vlanif10
ip address 10.1.10.1 255.255.255.0
[SW2]int vlan 11
[SW2-Vlanif11]di this
interface Vlanif11
ip address 10.1.11.1 255.255.255.0
[SW2-Vlanif11]int vlan 12
[SW2-Vlanif12]di this
interface Vlanif12
ip address 10.1.12.1 255.255.255.0
[SW2-Vlanif12]int vlan13
[SW2-Vlanif13]di this
interface Vlanif13
ip address 10.1.13.1 255.255.255.0
配置dhcp服务器(全局地址池)
[SW2]ip pool vlan10
Info:It's successful to create an IP address pool.
[SW2-ip-pool-vlan10]network 10.1.10.0 mask 24
[SW2-ip-pool-vlan10]gateway-list 10.1.10.1
[SW2-ip-pool-vlan10]dns-list 1.1.1.1
[SW2]ip pool vlan11
Info:It's successful to create an IP address pool.
[SW2-ip-pool-vlan11]network 10.1.11.0 mask 24
[SW2-ip-pool-vlan11]gateway-list 10.1.11.1
[SW2-ip-pool-vlan11]dns-list 1.1.1.1
[SW2]ip pool vlan12
Info:It's successful to create an IP address pool.
[SW2-ip-pool-vlan12]network 10.1.12.0 mask 24
[SW2-ip-pool-vlan12]gateway-list 10.1.12.1
[SW2-ip-pool-vlan12]dns-list 1.1.1.1
[SW2]ip pool vlan13
Info:It's successful to create an IP address pool.
[SW2-ip-pool-vlan13]network 10.1.13.0 mask 24
[SW2-ip-pool-vlan13]gateway-list 10.1.13.1
[SW2-ip-pool-vlan13]dns-list 114.114.114.114
在每个vlanif中开启dhcp服务
[SW2-Vlanif10]dhcp select global
[SW2-Vlanif11]dhcp select global
[SW2-Vlanif12]dhcp select global
[SW2-Vlanif13]dhcp select global
这时候可以在AP上可以进行测试,看AP是否拿到地址
此时已经实现AP获取到IP地址,能够和AC之间三层可达
给AC配置IP地址(手动进行配置)
[AC6005]int Vlanif 10
[AC6005-Vlanif10]ip address 10.1.10.10 24
[AC6005-Vlanif10]quit
[AC6005]ip route-static 0.0.0.0 0 10.1.10.1
- AP注册到AC(配置AP上线)在AC上进行配置
[AC6005]capwap source interface vlan 10 指定capwap隧道的原接口
[AC6005]wlan
[AC6005-wlan-view]regulatory-domain-profile name domain1 创建域管理模板
[AC6005-wlan-regulate-domain-domain1]country-code CN
[AC6005]wlan
[AC6005-wlan-view]ap-group name group1 //创建AP组,名字为group1
[AC6005-wlan-ap-group-group1]regulatory-domain-profile name domain1 绑定域管理模板到AP组
[AC6005-wlan-regulate-domain-domain1]quit
[AC6005-wlan-view]ap auth-mode mac-auth //AP的认证方式为mac地址认证
[AC6005-wlan-view]ap-mac 00e0-fcf4-01b0 //AP1的mac地址
[AC6005-wlan-ap-0]ap-group group1 指定AP属于那个组
[AC6005-wlan-ap-0]quit
[AC6005-wlan-view]ap-mac 00e0-fc23-57f0 //AP1的mac地址
[AC6005-wlan-ap-1]ap-group group1
查看
这时AP已经注册到AC
下一步实现AC给AP下发WLAN业务
[AC6005]wlan
[AC6005-wlan-view]security-profile name anquan1 创建安全模板
[AC6005-wlan-sec-prof-anquan1]quit
[AC6005-wlan-view]ssid-profile name huawei1 创建第一个ssid模板
[AC6005-wlan-ssid-prof-huawei1]ssid huawei1 ssid模板名称
Info: This operation may take a few seconds, please wait.done.
[AC6005-wlan-ssid-prof-huawei1]quit
[AC6005-wlan-view]ssid-profile name huawei2 创建第一个ssid模板
[AC6005-wlan-ssid-prof-huawei2]ssid huawei2
[AC6005-wlan-view]vap-profile name vap1 创建vap模板
[AC6005-wlan-vap-prof-vap1]security-profile anquan1 调用安全模板
[AC6005-wlan-vap-prof-vap1]ssid-profile huawei1 调用ssid模板
Info: This operation may take a few seconds, please wait.done.
[AC6005-wlan-vap-prof-vap1]service-vlan vlan-id 11 绑定业务vlan
[AC6005-wlan-vap-prof-vap1]forward-mode direct-forward 定义转发模式
[AC6005-wlan-vap-prof-vap1]di this
#
service-vlan vlan-id 11
ssid-profile huawei1
security-profile anquan1
[AC6005-wlan-view]vap-profile name vap2
[AC6005-wlan-vap-prof-vap2]di this
#
service-vlan vlan-id 12
ssid-profile huawei2
security-profile anquan1
[AC6005-wlan-view]ap-group name group1 绑定vap模板到AP组
[AC6005-wlan-ap-group-group1]vap-profile vap1 wlan 1 radio all
[AC6005-wlan-ap-group-group1]vap-profile vap2 wlan 2 radio all
这时的拓扑图
圈圈是ap发射出来的无线电磁波