Integer Inquiry(UVA—424)

题目:

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration ofpowers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.“This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.”(Chip moved to a new apartment, once one became available on the third floor of the Lemon Skyapartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInte-ger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (noVeryLongInteger will be negative).The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

<font color=red Sample Output

370370367037037036703703703670

解题思路:这个题是高精度的问题,多个大数相加的结果.

程序代码:

#include<stdio.h>
#include<string.h>
int a[50000],b[50000],c[55000];
char s[200];
int main()
{
	int n,m,i,j,k;
	memset(a,0,sizeof(a));
	scanf("%s",s);
	m=strlen(s);
	j=0;
	for(i=m-1;i>=0;i--)
		a[j++]=s[i]-'0';
	while(scanf("%s",s)!=EOF)
	{
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		if(s[0]=='0')
			break;
		n=strlen(s);
		j=0;
		for(i=n-1;i>=0;i--)
			b[j++]=s[i]-'0';
		if(n>m)
			k=n;
		else
			k=m;
		for(i=0;i<k;i++)
		{
			c[i]=a[i]+b[i]+c[i];
			if(c[i]>=10)
			{
				c[i+1]++;
				c[i]=c[i]%10;
			}
		}
		if(c[k]!=0)
			k++;
		for(i=0;i<k;i++)
			a[i]=c[i];
		m=k;	
	}
	for(i=m-1;i>=0;i--)
		printf("%d",a[i]);
	printf("\n");
	return 0;	
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值