CSU-ACM2019寒假训练1-G - 相当简单题

这道题相当不错欸,大数字运算的处理方式,学到了(ง •_•)ง
题目:
One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
"This supercomputer is great,’’ remarked Chip. ``I only wish Timothy were here to see these results.’’ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output
Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670

日常翻译:ˋ( ° ▽、° )
比特新超级计算机的首批用户之一是芯片迪勒(Chip Diller)。他把对3的幂的研究从0扩展到333他研究了这些数的各种和。
“这台超级计算机太棒了,”奇普说。我只希望提摩太能在这里看到这些结果。(奇普搬到了一套新公寓,有一次在第三街柠檬天空公寓(Lemon Sky apartments)的三楼有了一套。)

输入
输入最多由100行文本组成,每个文本包含一个非常长的整数。每个VeryLongInteger的长度为100个或更少的字符,并且只包含数字(没有VeryLongInteger是负数)。
最后的输入行将在一行中单独包含一个0。

输出
您的程序应该输出输入中给定的非常长的整数的和。

思路:将大数字转化为字符串进行单个处理,然后运用小学时候的加减方法,遇到10就向前进一位,然后一位位的判断,注意将更长的数字放在上面相加(加减法),这样多的位数便于判断~

代码如下:

#include<iostream>
#include<string>
using namespace std;
string p(string a,string b)//这个用来将更长的数字放在上面
{
	if(a.size()<b.size())
	{
	  string temp=b;
	   b=a;
	   a=temp;
    }
int la=a.size(),lb=b.size(),x,y,sum,flag=0;//flag只能为1或者0,自己想想
while(la>0)
{
  x=a[la-1]-'0';  //得到每一位数字
  if(lb>0)
  y=b[lb-1]-'0'; 
  else
  y=0;                //如果下面位数不够,就当0处理
  sum=x+y+flag;   
  if(sum>=10)         //如果大于等于10,就进一位
  {
  	flag=1;      
  	a[la-1]='0'+sum%10;
   }
   else                    //反之则不进一位
	{a[la-1]='0'+sum;
	 flag=0;}
  la--;
  lb--;
}
if(flag==1)              //最后若要进一位,用字符串相加即可
  a="1"+a;  
return a;
}
int main()
{
	string s1,s2;
	cin>>s1;
	while(cin>>s2&&s2!="0")
	{s1=p(s1,s2);}
	cout<<s1;
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值